summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Predis-upstream.patch60
-rw-r--r--php-nrk-Predis.spec9
2 files changed, 6 insertions, 63 deletions
diff --git a/Predis-upstream.patch b/Predis-upstream.patch
deleted file mode 100644
index 22bea4a..0000000
--- a/Predis-upstream.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From d09c4f32f3650d30f84c90f161304a4034a0f86f Mon Sep 17 00:00:00 2001
-From: Daniele Alessandri <suppakilla@gmail.com>
-Date: Tue, 21 Oct 2014 11:16:55 +0200
-Subject: [PATCH] [tests] Relax checks on invalid expire time messages.
-
-Previously there was a bug in Redis that returned the wrong command
-in -ERR messages when passing an invalid expire time with SETEX and
-PSETEX. Now that the bug has been fixed and that travis-ci uses a an
-updated version of Redis, our test suite turned red.
----
- tests/Predis/Command/StringPreciseSetExpireTest.php | 6 ++----
- tests/Predis/Command/StringSetExpireTest.php | 4 ++--
- 2 files changed, 4 insertions(+), 6 deletions(-)
-
-diff --git a/tests/Predis/Command/StringPreciseSetExpireTest.php b/tests/Predis/Command/StringPreciseSetExpireTest.php
-index 77df02c..c93744e 100644
---- a/tests/Predis/Command/StringPreciseSetExpireTest.php
-+++ b/tests/Predis/Command/StringPreciseSetExpireTest.php
-@@ -93,8 +93,7 @@ public function testThrowsExceptionOnNonIntegerTTL()
- /**
- * @group connected
- * @expectedException \Predis\Response\ServerException
-- * @expectedExceptionMessage ERR invalid expire time in SETEX
-- * @todo Should not Redis return PSETEX instead of SETEX here?
-+ * @expectedExceptionMessage ERR invalid expire time
- */
- public function testThrowsExceptionOnZeroTTL()
- {
-@@ -104,8 +103,7 @@ public function testThrowsExceptionOnZeroTTL()
- /**
- * @group connected
- * @expectedException \Predis\Response\ServerException
-- * @expectedExceptionMessage ERR invalid expire time in SETEX
-- * @todo Should not Redis return PSETEX instead of SETEX here?
-+ * @expectedExceptionMessage ERR invalid expire time
- */
- public function testThrowsExceptionOnNegativeTTL()
- {
-diff --git a/tests/Predis/Command/StringSetExpireTest.php b/tests/Predis/Command/StringSetExpireTest.php
-index 59ff77b..b52e9fa 100644
---- a/tests/Predis/Command/StringSetExpireTest.php
-+++ b/tests/Predis/Command/StringSetExpireTest.php
-@@ -94,7 +94,7 @@ public function testThrowsExceptionOnNonIntegerTTL()
- /**
- * @group connected
- * @expectedException \Predis\Response\ServerException
-- * @expectedExceptionMessage ERR invalid expire time in SETEX
-+ * @expectedExceptionMessage ERR invalid expire time
- */
- public function testThrowsExceptionOnZeroTTL()
- {
-@@ -104,7 +104,7 @@ public function testThrowsExceptionOnZeroTTL()
- /**
- * @group connected
- * @expectedException \Predis\Response\ServerException
-- * @expectedExceptionMessage ERR invalid expire time in SETEX
-+ * @expectedExceptionMessage ERR invalid expire time
- */
- public function testThrowsExceptionOnNegativeTTL()
- {
diff --git a/php-nrk-Predis.spec b/php-nrk-Predis.spec
index 8b0a811..f8e602e 100644
--- a/php-nrk-Predis.spec
+++ b/php-nrk-Predis.spec
@@ -10,14 +10,14 @@
%global pear_name Predis
%global pear_channel pear.nrk.io
-%if 0%{?fedora} >= 19 || 0%{?rhel} >= 7
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 7
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%else
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%endif
Name: php-nrk-Predis
-Version: 1.0.1
+Version: 1.0.2
Release: 1%{?dist}
Summary: PHP client library for Redis
@@ -33,7 +33,7 @@ BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
%if %{with_tests}
BuildRequires: php-phpunit-PHPUnit
-BuildRequires: redis > 2.6
+BuildRequires: redis > 2.8
%endif
Requires(post): %{__pear}
@@ -140,6 +140,9 @@ fi
%changelog
+* Thu Jul 30 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- Update to 1.0.2
+
* Fri Jan 02 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
- Update to 1.0.1