summaryrefslogtreecommitdiffstats
path: root/php-nikic-php-parser4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nikic-php-parser4.spec')
-rw-r--r--php-nikic-php-parser4.spec11
1 files changed, 9 insertions, 2 deletions
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index 5aaf346..631d415 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -22,7 +22,7 @@
Name: php-%{gh_owner}-%{pk_project}%{major}
Version: 4.11.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A PHP parser written in PHP - version %{major}
License: BSD
@@ -32,6 +32,8 @@ Source1: makesrc.sh
# Autoloader
Patch0: %{name}-rpm.patch
+# For PHP 8.1
+Patch1: %{name}-upstream.patch
BuildArch: noarch
%if %{with_tests}
@@ -86,6 +88,7 @@ Autoloader: %{php_home}/%{ns_project}%{major}/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1
%build
@@ -132,7 +135,8 @@ ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 -d auto_prepend_file=%{buildroot}/%{php_home}/%{ns_project}%{major}/autoload.php \
+ $1 -d include_path=%{php_home} \
+ -d auto_prepend_file=%{buildroot}/%{php_home}/%{ns_project}%{major}/autoload.php \
${2:-%{_bindir}/phpunit9} $FILTER --verbose || ret=1
fi
done
@@ -153,6 +157,9 @@ exit $ret
%changelog
+* Wed Jul 21 2021 Remi Collet <remi@remirepo.net> - 4.11.0-2
+- add upstream patches for PHP 8.1
+
* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 4.11.0-1
- update to 4.11.0
- switch to phpunit9