summaryrefslogtreecommitdiffstats
path: root/php-nette-reflection.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nette-reflection.spec')
-rw-r--r--php-nette-reflection.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-nette-reflection.spec b/php-nette-reflection.spec
index a35f561..f00b1d9 100644
--- a/php-nette-reflection.spec
+++ b/php-nette-reflection.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9c2ed2a29f1f58125a0f19ffc987812d6b17d3e6
+%global gh_commit 6c39adc4661f5f7b64be7ee161b8f67d8174da4d
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.1
+Version: 2.3.2
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette PHP Reflection Component
@@ -113,7 +113,12 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-nette-tester --colors 0 -p php -c ./php.ini tests -s
+%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
+
+if which php70; then
+ cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
+ php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+fi
%else
: Test suite disabled
%endif
@@ -134,5 +139,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Apr 2 2016 Remi Collet <remi@fedoraproject.org> - 2.3.2-1
+- update to 2.3.2
+- run test suite with both php 5 and 7 when available
+
* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 2.3.1-1
-- initial package \ No newline at end of file
+- initial package