summaryrefslogtreecommitdiffstats
path: root/php-nette-di.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-06 09:24:34 +0200
committerRemi Collet <remi@remirepo.net>2017-08-06 09:24:34 +0200
commit7caa73d85f86e923b2451077fcd2f93a37bf085e (patch)
treefa9cfc7ede9a0f32fbed067a2c3c2d78f775a894 /php-nette-di.spec
parentc3b0b5bd58f0ebe78d24a295b1cefcbe6244935c (diff)
v2.4.9
Diffstat (limited to 'php-nette-di.spec')
-rw-r--r--php-nette-di.spec33
1 files changed, 10 insertions, 23 deletions
diff --git a/php-nette-di.spec b/php-nette-di.spec
index 11ce220..4ef6a10 100644
--- a/php-nette-di.spec
+++ b/php-nette-di.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit b3fe8551162279216e251e49b406e55cd2d255d5
+%global gh_commit 25437788ff126d0ae6b1f2f684ecdd823812abba
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.8
+Version: 2.4.9
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Dependency Injection Component
@@ -29,7 +29,6 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# pull a git snapshot to get test sutie
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
@@ -101,7 +100,6 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
@@ -122,33 +120,19 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C tests -s
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -d serialize_precision=14 -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license license.md
%doc readme.md contributing.md
@@ -158,6 +142,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Aug 5 2017 Remi Collet <remi@remirepo.net> - 2.4.9-1
+- Update to 2.4.9
+
* Mon Mar 20 2017 Remi Collet <remi@remirepo.net> - 2.4.8-1
- Update to 2.4.8
- raise dependency on nette/php-generator 2.6.1