From 17f49c6686f6b62f7306523948f125638c17b1cb Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Mon, 19 Aug 2019 14:11:12 +0200
Subject: - update to 1.6.0 - drop patch merged upstream

---
 131.patch                       | 22 ----------------------
 composer.json                   |  6 +++++-
 php-netresearch-jsonmapper.spec | 28 +++++++++++++++++++---------
 3 files changed, 24 insertions(+), 32 deletions(-)
 delete mode 100644 131.patch

diff --git a/131.patch b/131.patch
deleted file mode 100644
index 5b173f6..0000000
--- a/131.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 6cdf7da6d2ff3affa0bc3fbf5517278abc23b3b8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 8 Aug 2019 09:48:05 +0200
-Subject: [PATCH] fix Trying to access array offset on value of type null
-
----
- src/JsonMapper.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/JsonMapper.php b/src/JsonMapper.php
-index 2056ead..2bf1daf 100644
---- a/src/JsonMapper.php
-+++ b/src/JsonMapper.php
-@@ -592,7 +592,7 @@ protected function getMappedType($type, $jvalue = null)
-     {
-         if (isset($this->classMap[$type])) {
-             $target = $this->classMap[$type];
--        } else if ($type !== '' && $type[0] == '\\'
-+        } else if (is_string($type) && $type !== '' && $type[0] == '\\'
-             && isset($this->classMap[substr($type, 1)])
-         ) {
-             $target = $this->classMap[substr($type, 1)];
diff --git a/composer.json b/composer.json
index de7817d..305b2d5 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,11 @@
         "issues": "https://github.com/cweiske/jsonmapper/issues"
     },
     "require":{
-      "php": ">=5.6"
+        "php": ">=5.6",
+        "ext-spl": "*",
+        "ext-json": "*",
+        "ext-pcre": "*",
+        "ext-reflection": "*"
     },
     "require-dev": {
         "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
diff --git a/php-netresearch-jsonmapper.spec b/php-netresearch-jsonmapper.spec
index 41f35ca..f5d775d 100644
--- a/php-netresearch-jsonmapper.spec
+++ b/php-netresearch-jsonmapper.spec
@@ -6,7 +6,7 @@
 #
 # Please, preserve the changelog entries
 #
-%global gh_commit    caf41ab74ac7252f5f46db6c16ab0a8358e2e55c
+%global gh_commit    0d4d1b48d682a93b6bfedf60b88c7750e9cb0b06
 %global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
 %global gh_owner     cweiske
 %global gh_project   jsonmapper
@@ -18,7 +18,7 @@
 %global with_tests   0%{!?_without_tests:1}
 
 Name:           php-%{pk_vendor}-%{pk_project}
-Version:        1.5.2
+Version:        1.6.0
 Release:        1%{?dist}
 Summary:        Map nested JSON structures onto PHP classes
 
@@ -28,14 +28,14 @@ Source0:        %{name}-%{version}-%{gh_short}.tgz
 # Git snapshot with tests
 Source1:        makesrc.sh
 
-Patch0:         https://patch-diff.githubusercontent.com/raw/cweiske/jsonmapper/pull/131.patch
-
 BuildArch:      noarch
 %if %{with_tests}
 # For tests
 BuildRequires:  php(language) >= 5.6
-BuildRequires:  php-pcre
 BuildRequires:  php-spl
+BuildRequires:  php-json
+BuildRequires:  php-pcre
+BuildRequires:  php-reflection
 # From composer.json, "require-dev": {
 #        "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
 #        "squizlabs/php_codesniffer": "~1.5"
@@ -51,11 +51,18 @@ BuildRequires:  php-fedora-autoloader-devel
 %endif
 
 # From composer.json, "require": {
-#      "php": ">=5.6"
+#        "php": ">=5.6",
+#        "ext-spl": "*",
+#        "ext-json": "*",
+#        "ext-pcre": "*",
+#        "ext-reflection": "*"
 Requires:       php(language) >= 5.6
-# From phpcompatinfo report for version 1.3.0
-Requires:       php-pcre
 Requires:       php-spl
+Requires:       php-json
+Requires:       php-pcre
+Requires:       php-reflection
+# From phpcompatinfo report for version 1.6.0
+# none
 # Required by autoloader
 Requires:       php-composer(fedora/autoloader)
 
@@ -83,7 +90,6 @@ Autoloader: %{php_home}/%{pk_vendor}/%{pk_project}/autoload.php
 
 %prep
 %setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
 
 
 %build
@@ -127,6 +133,10 @@ exit $ret
 
 
 %changelog
+* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- drop patch merged upstream
+
 * Thu Aug  8 2019 Remi Collet <remi@remirepo.net> - 1.5.2-1
 - update to 1.5.2
 - add patch for PHP 7.4 from
-- 
cgit