summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-myclabs-php-enum.spec29
2 files changed, 20 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 6861a5c..73caf14 100644
--- a/composer.json
+++ b/composer.json
@@ -22,12 +22,12 @@
}
},
"require": {
- "php": ">=7.1",
+ "php": "^7.3 || ^8.0",
"ext-json": "*"
},
"require-dev": {
- "phpunit/phpunit": "^7",
+ "phpunit/phpunit": "^9.5",
"squizlabs/php_codesniffer": "1.*",
- "vimeo/psalm": "^3.8"
+ "vimeo/psalm": "^4.5.1"
}
}
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
index 5539048..128c3de 100644
--- a/php-myclabs-php-enum.spec
+++ b/php-myclabs-php-enum.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-myclabs-php-enum
#
-# Copyright (c) 2017-2020 Remi Collet
+# Copyright (c) 2017-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit d178027d1e679832db9f38248fcc7200647dc2b7
+%global gh_commit 46cf3d8498b095bd33727b13fd5707263af99421
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project php-enum
@@ -20,7 +20,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.7.7
+Version: 1.8.0
Release: 1%{?dist}
Summary: PHP Enum implementation
@@ -33,24 +33,24 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
BuildRequires: php-json
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^7",
+# "phpunit/phpunit": "^9.5",
# "squizlabs/php_codesniffer": "1.*"
-# "vimeo/psalm": "^3.8"
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: %{phpunit}
+# "vimeo/psalm": "^4.5.1"
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=7.1",
+# "php": "^7.3 || ^8.0",
# "ext-json": "*"
-Requires: php(language) >= 7.1
+Requires: php(language) >= 7.3
Requires: php-json
# From phpcompatinfo report for version 1.6.1
Requires: php-reflection
@@ -99,10 +99,10 @@ require __DIR__ . '/bootstrap.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php72 php73 php74 php80; do
+for cmd in "php %{phpunit}" php73 php74 php80; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} --verbose --bootstrap tests/autoload.php || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose --bootstrap tests/autoload.php || ret=1
fi
done
exit $ret
@@ -121,6 +121,11 @@ exit $ret
%changelog
+* Tue Feb 16 2021 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Mon Nov 16 2020 Remi Collet <remi@remirepo.net> - 1.7.7-1
- update to 1.7.7