summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rwxr-xr-xmakesrc.sh26
-rw-r--r--php-myclabs-deep-copy-autoload.php15
-rw-r--r--php-myclabs-deep-copy.spec112
4 files changed, 157 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..05a6054
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,26 @@
+#!/bin/bash
+
+NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-myclabs-deep-copy-autoload.php b/php-myclabs-deep-copy-autoload.php
new file mode 100644
index 0000000..efb6bb4
--- /dev/null
+++ b/php-myclabs-deep-copy-autoload.php
@@ -0,0 +1,15 @@
+<?php
+/* Autoloader for myclabs/deep-copy and its dependencies */
+
+$vendorDir = '/usr/share/php';
+// Use Symfony autoloader
+if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
+ if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
+ require_once $vendorDir . '/Symfony/Component/ClassLoader/ClassLoader.php';
+ }
+
+ $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
+ $fedoraClassLoader->register();
+}
+
+$fedoraClassLoader->addPrefix('DeepCopy\\', dirname(__DIR__));
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
new file mode 100644
index 0000000..22232ef
--- /dev/null
+++ b/php-myclabs-deep-copy.spec
@@ -0,0 +1,112 @@
+# remirepo spec/Fedora file for php-myclabs-deep-copy
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 96fbdc07635989c35c5a1912379f4c4b2ab15fd5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner myclabs
+%global gh_project DeepCopy
+%global c_project deep-copy
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-myclabs-deep-copy
+Version: 1.3.0
+Release: 1%{?dist}
+Summary: Create deep copies (clones) of your objects
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snashop to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+Source2: %{name}-autoload.php
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.4
+BuildRequires: php-reflection
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "doctrine/collections": "1.*",
+# "phpunit/phpunit": "~4.1"
+BuildRequires: php-composer(doctrine/collections) >= 1
+BuildRequires: php-composer(phpunit/phpunit) >= 4.1
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.4.0"
+Requires: php(language) >= 5.4
+# From phpcompatinfo report for version 1.3.0
+Requires: php-reflection
+Requires: php-spl
+
+Provides: php-composer(%{gh_owner}/%{c_project}) = %{version}
+
+
+%description
+DeepCopy helps you create deep copies (clones) of your objects.
+It is designed to handle cycles in the association graph.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+# https://github.com/myclabs/DeepCopy/pull/14
+find . -type f -exec chmod -x {} \;
+
+cp %{SOURCE2} src/%{gh_project}/autoload.php
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+
+: Library
+mkdir -p %{buildroot}%{php_home}
+cp -pr src/%{gh_project} %{buildroot}%{php_home}/%{gh_project}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{gh_project}/autoload.php';
+\$fedoraClassLoader->addPrefix('DeepCopyTest\\\\', __DIR__ . '/../tests');
+\$fedoraClassLoader->addPrefix('Doctrine\\\\', '%{php_home}');
+EOF
+
+%{_bindir}/phpunit --verbose
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%{php_home}/%{gh_project}
+
+
+%changelog
+* Sat Jul 4 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- initial package, version 1.3.0
+- open https://github.com/myclabs/DeepCopy/pull/14 - fix perms \ No newline at end of file