summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-myclabs-deep-copy-autoload.php9
-rw-r--r--php-myclabs-deep-copy.spec9
2 files changed, 9 insertions, 9 deletions
diff --git a/php-myclabs-deep-copy-autoload.php b/php-myclabs-deep-copy-autoload.php
index 26343f0..3ed49e9 100644
--- a/php-myclabs-deep-copy-autoload.php
+++ b/php-myclabs-deep-copy-autoload.php
@@ -1,10 +1,7 @@
<?php
/* Autoloader for myclabs/deep-copy and its dependencies */
-if (!function_exists("DeepCopy\\deep_copy")) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
- require_once __DIR__ . '/deep_copy.php';
-
- \Fedora\Autoloader\Autoload::addPsr4('DeepCopy\\', __DIR__);
-}
+require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+require_once __DIR__ . '/deep_copy.php';
+\Fedora\Autoloader\Autoload::addPsr4('DeepCopy\\', __DIR__);
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
index 7df5007..0973348 100644
--- a/php-myclabs-deep-copy.spec
+++ b/php-myclabs-deep-copy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 478465659fd987669df0bd8a9bf22a8710e5f1b6
+%global gh_commit 3e01bdad3e18354c3dce54466b7fbe33a9f9f7f8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project DeepCopy
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-myclabs-deep-copy
-Version: 1.8.0
+Version: 1.8.1
Release: 1%{?dist}
Summary: Create deep copies (clones) of your objects
@@ -100,7 +100,7 @@ require_once '%{php_home}/Doctrine/Common/autoload.php';
EOF
ret=0
-for cmd in php php71 php72; do
+for cmd in php php71 php72 php73; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{gh_project}/autoload.php \
%{_bindir}/phpunit7 --verbose || ret=1
@@ -121,6 +121,9 @@ exit $ret
%changelog
+* Tue Jun 12 2018 Remi Collet <remi@remirepo.net> - 1.8.1-1
+- update to 1.8.1
+
* Wed May 30 2018 Remi Collet <remi@remirepo.net> - 1.8.0-1
- update to 1.8.0 (no change)
- raise dependency on PHP 7.1