summaryrefslogtreecommitdiffstats
path: root/php-mockery.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-mockery.spec')
-rw-r--r--php-mockery.spec16
1 files changed, 11 insertions, 5 deletions
diff --git a/php-mockery.spec b/php-mockery.spec
index f8159b2..5f5b29f 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit 1bac8c362b12f522fdd1f1fa3556284c91affa38
+%global gh_commit 99e29d3596b16dabe4982548527d5ddf90232e99
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner padraic
%global gh_project mockery
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-mockery
-Version: 1.0
+Version: 1.1.0
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -34,13 +34,14 @@ Patch2: 798.patch
BuildArch: noarch
%if %{with_tests}
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~5.7|~6.1"
+# "phpunit/phpunit": "~5.7.10|~6.5",
+# "phpdocumentor/phpdocumentor": "^2.9"
%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6
+BuildRequires: phpunit6 >= 6.5
%else
%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 5.7
+BuildRequires: php-phpunit-PHPUnit >= 5.7.10
%endif
BuildRequires: php(language) >= 5.6.0
%if 0%{?fedora} >= 27
@@ -113,6 +114,8 @@ cp -rp library/%{ns_project} %{buildroot}/%{_datadir}/php/%{ns_project}%{major}
: Use installed tree and our autoloader
export COMPOSER_VENDOR_DIR=%{buildroot}%{_datadir}/php/%{ns_project}%{major}
+phpab --output tests/classmap.php tests/Mockery/Stubs/
+
: Run upstream test suite
ret=0
for cmd in "php %{phpunit}" php70 php71 php72; do
@@ -137,6 +140,9 @@ exit $ret
%changelog
+* Sun May 13 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Mon Jan 22 2018 Remi Collet <remi@remirepo.net> - 1.0-1
- Update to 1.0
- rename to php-mockery and move to /usr/share/php/Mockery1