summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-mockery.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 4d7c96c..4534259 100644
--- a/composer.json
+++ b/composer.json
@@ -36,7 +36,7 @@
"hamcrest/hamcrest-php": "~2.0"
},
"require-dev": {
- "phpunit/phpunit": "~5.7.10|~6.5|~7.0"
+ "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0"
},
"autoload": {
"psr-0": {
diff --git a/php-mockery.spec b/php-mockery.spec
index 1d33c79..05251a8 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit 100633629bf76d57430b86b7098cd6beb996a35a
+%global gh_commit dc4f10b6b1148744facb784015e4b339d7feec23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-mockery
-Version: 1.2.0
+Version: 1.2.1
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -32,7 +32,7 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 5.6.0
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~5.7.10|~6.5|~7.0"
+# "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
@@ -114,7 +114,7 @@ phpab --output tests/classmap.php --exclude */SemiReservedWordsAsMethods.php tes
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
+for cmd in "php %{phpunit}" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit7" php72 php73; do
if which $cmd; then
set $cmd
# see .travis.yml
@@ -122,7 +122,7 @@ for cmd in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
then SUITE="Mockery Test Suite PHP56"
else SUITE="Mockery Test Suite"
fi
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit8} \
--no-coverage \
--verbose --testsuite="$SUITE"
fi
@@ -141,6 +141,9 @@ exit $ret
%changelog
+* Mon Feb 11 2019 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+
* Wed Oct 3 2018 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0
- switch to phpunit7