summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--mockery-tests.patch18
-rw-r--r--php-mockery.spec7
3 files changed, 24 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index d1382d5..bc6b77b 100644
--- a/composer.json
+++ b/composer.json
@@ -62,7 +62,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.4.x-dev"
+ "dev-main": "1.6.x-dev"
}
},
"scripts": {
diff --git a/mockery-tests.patch b/mockery-tests.patch
new file mode 100644
index 0000000..3019204
--- /dev/null
+++ b/mockery-tests.patch
@@ -0,0 +1,18 @@
+diff -up ./tests/Bootstrap.php.rpm ./tests/Bootstrap.php
+--- ./tests/Bootstrap.php.rpm 2018-05-08 10:54:48.000000000 +0200
++++ ./tests/Bootstrap.php 2018-05-13 10:39:38.471383840 +0200
+@@ -50,11 +50,9 @@ if (!file_exists($autoloadPath)) {
+
+ require_once $autoloadPath;
+
+-$hamcrestRelativePath = 'hamcrest/hamcrest-php/hamcrest/Hamcrest.php';
+-if (DIRECTORY_SEPARATOR !== '/') {
+- $hamcrestRelativePath = str_replace('/', DIRECTORY_SEPARATOR, $hamcrestRelativePath);
+-}
+-$hamcrestPath = $composerVendorDirectory . DIRECTORY_SEPARATOR . $hamcrestRelativePath;
++require_once __DIR__ . '/classmap.php';
++
++$hamcrestPath = '/usr/share/php/Hamcrest2/Hamcrest.php';
+
+ require_once $hamcrestPath;
+
diff --git a/php-mockery.spec b/php-mockery.spec
index 9e55aa8..e201e6b 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -9,7 +9,7 @@
#
%bcond_without tests
-%global gh_commit a8dd186f07ea667c1e3abd2176bfab0ab161ea94
+%global gh_commit 13a7fa2642c76c58fa2806ef7f565344c817a191
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -17,7 +17,7 @@
%global major 1
Name: php-mockery
-Version: 1.6.1
+Version: 1.6.2
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -142,6 +142,9 @@ exit $ret
%changelog
+* Thu Jun 8 2023 Remi Collet <remi@remirepo.net> - 1.6.2-1
+- update to 1.6.2
+
* Tue Jun 6 2023 Remi Collet <remi@remirepo.net> - 1.6.1-1
- update to 1.6.1