summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--798.patch47
-rw-r--r--php-mockery.spec6
2 files changed, 1 insertions, 52 deletions
diff --git a/798.patch b/798.patch
deleted file mode 100644
index f0e29fb..0000000
--- a/798.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -up tests/Mockery/DemeterChainTest.php.test tests/Mockery/DemeterChainTest.php
-diff -up tests/Mockery/ExpectationTest.php.test tests/Mockery/ExpectationTest.php
---- tests/Mockery/ExpectationTest.php.test 2017-10-06 18:20:43.000000000 +0200
-+++ tests/Mockery/ExpectationTest.php 2018-01-22 10:42:30.193764672 +0100
-@@ -1309,14 +1309,14 @@ class ExpectationTest extends MockeryTes
-
- public function testObjectConstraintMatchesArgument()
- {
-- $this->mock->shouldReceive('foo')->with(Mockery::type('object'))->once();
-+ $this->mock->shouldReceive('foo')->with(Mockery::type('stdClass'))->once();
- $this->mock->foo(new stdClass);
- }
-
- public function testObjectConstraintNonMatchingCase()
- {
- $this->mock->shouldReceive('foo')->times(3);
-- $this->mock->shouldReceive('foo')->with(1, Mockery::type('object`'))->never();
-+ $this->mock->shouldReceive('foo')->with(1, Mockery::type('stdClass`'))->never();
- $this->mock->foo();
- $this->mock->foo(1);
- $this->mock->foo(1, 2, 3);
-@@ -1327,7 +1327,7 @@ class ExpectationTest extends MockeryTes
- */
- public function testObjectConstraintThrowsExceptionWhenConstraintUnmatched()
- {
-- $this->mock->shouldReceive('foo')->with(Mockery::type('object'));
-+ $this->mock->shouldReceive('foo')->with(Mockery::type('stdClass'));
- $this->mock->foo('f');
- Mockery::close();
- }
-diff -up tests/Mockery/NamedMockTest.php.test tests/Mockery/NamedMockTest.php
---- tests/Mockery/NamedMockTest.php.test 2017-10-06 18:20:43.000000000 +0200
-+++ tests/Mockery/NamedMockTest.php 2018-01-22 10:40:50.894254568 +0100
-@@ -35,11 +35,11 @@ class NamedMockTest extends MockeryTestC
- /** @test */
- public function itCreatesPassesFurtherArgumentsJustLikeMock()
- {
-- $mock = Mockery::namedMock("Mockery\Dave456", "DateTime", array(
-+ $mock = Mockery::namedMock("Mockery\Dave456", "DateTimeZone", array(
- "getDave" => "dave"
- ));
-
-- $this->assertInstanceOf("DateTime", $mock);
-+ $this->assertInstanceOf("DateTimeZone", $mock);
- $this->assertEquals("dave", $mock->getDave());
- }
-
diff --git a/php-mockery.spec b/php-mockery.spec
index 5f5b29f..2b9759a 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -9,7 +9,7 @@
#
%global gh_commit 99e29d3596b16dabe4982548527d5ddf90232e99
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner padraic
+%global gh_owner mockery
%global gh_project mockery
%global ns_project Mockery
%global major 1
@@ -27,9 +27,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Use our autoloader
Patch0: %{gh_project}-tests.patch
-# Patch for 7.2
-# From https://github.com/mockery/mockery/pull/798
-Patch2: 798.patch
BuildArch: noarch
%if %{with_tests}
@@ -95,7 +92,6 @@ cat << 'EOF' | tee -a library/%{ns_project}/autoload.php
EOF
%patch0 -p0 -b .rpm
-%patch2 -p0 -b .test
rm -f docs/.gitignore