summaryrefslogtreecommitdiffstats
path: root/php-mockery.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-19 17:17:28 +0200
committerRemi Collet <remi@remirepo.net>2019-08-19 17:17:28 +0200
commitd93ddcf5b67359ccb0a9a110f20f79308a67f026 (patch)
tree3fdedfd6ad9fc1e1073d5aa14acf00d9ab9ea253 /php-mockery.spec
parenteadf7439b126bfa834faa404d727f65062f288b4 (diff)
- update to 1.2.3
- add patch for PHP 7.4 from https://github.com/mockery/mockery/pull/993
Diffstat (limited to 'php-mockery.spec')
-rw-r--r--php-mockery.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-mockery.spec b/php-mockery.spec
index de799de..2adae20 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit 0eb0b48c3f07b3b89f5169ce005b7d05b18cf1d2
+%global gh_commit 4eff936d83eb809bde2c57a3cea0ee9643769031
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-mockery
-Version: 1.2.2
+Version: 1.2.3
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -26,6 +26,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Use our autoloader
Patch0: %{gh_project}-tests.patch
+# For 7.4
+Patch1: https://patch-diff.githubusercontent.com/raw/mockery/mockery/pull/993.patch
BuildArch: noarch
%if %{with_tests}
@@ -91,6 +93,7 @@ cat << 'EOF' | tee -a library/%{ns_project}/autoload.php
EOF
%patch0 -p0 -b .rpm
+%patch1 -p1
rm -f docs/.gitignore
@@ -111,9 +114,10 @@ export COMPOSER_VENDOR_DIR=%{buildroot}%{_datadir}/php/%{ns_project}%{major}
phpab --output tests/classmap.php --exclude */SemiReservedWordsAsMethods.php tests/Mockery
+# TODO 7.4 Function is_real() is deprecated
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit7" php72 php73; do
+for cmd in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
if which $cmd; then
set $cmd
# see .travis.yml
@@ -123,7 +127,7 @@ for cmd in "php %{phpunit}" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpuni
fi
$1 ${2:-%{_bindir}/phpunit8} \
--no-coverage \
- --verbose --testsuite="$SUITE"
+ --verbose --testsuite="$SUITE" || ret=1
fi
done
exit $ret
@@ -140,6 +144,11 @@ exit $ret
%changelog
+* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+- add patch for PHP 7.4 from
+ https://github.com/mockery/mockery/pull/993
+
* Wed Feb 13 2019 Remi Collet <remi@remirepo.net> - 1.2.2-1
- update to 1.2.2