summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-25 09:18:45 +0100
committerRemi Collet <remi@remirepo.net>2019-11-25 09:18:45 +0100
commit13597af0029f40a9b7c19374fb137c9d9262d058 (patch)
tree5642883b9fc3d9a923b9f49e1c9c852afb3d2de5
parent1ba978a5574162c4f34e3ea078705c1fe5fb1b02 (diff)
-rw-r--r--composer.json5
-rw-r--r--php-mockery.spec16
2 files changed, 14 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 4534259..a2bbde9 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,8 @@
"require": {
"php": ">=5.6.0",
"lib-pcre": ">=7.0",
- "hamcrest/hamcrest-php": "~2.0"
+ "hamcrest/hamcrest-php": "~2.0",
+ "sebastian/comparator": "^1.2.4|^3.0"
},
"require-dev": {
"phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0"
@@ -50,7 +51,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.0.x-dev"
+ "dev-master": "1.2.x-dev"
}
}
}
diff --git a/php-mockery.spec b/php-mockery.spec
index a4c1b05..90a5792 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit b3453f75fd23d9fd41685f2148f4abeacabc6405
+%global gh_commit 5571962a4f733fbb57bede39778f71647fae8e66
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-mockery
-Version: 1.2.4
+Version: 1.3.0
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -34,8 +34,8 @@ BuildRequires: php(language) >= 5.6.0
# "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8
BuildRequires: (php-composer(hamcrest/hamcrest-php) >= 2.0 with php-composer(hamcrest/hamcrest-php) < 3)
# remirepo:5
%else
@@ -50,11 +50,13 @@ BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.6.0",
# "lib-pcre": ">=7.0",
-# "hamcrest/hamcrest-php": "~2.0"
+# "hamcrest/hamcrest-php": "~2.0",
+# "sebastian/comparator": "^1.2.4|^3.0"
Requires: php(language) >= 5.6.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(hamcrest/hamcrest-php) >= 2.0 with php-composer(hamcrest/hamcrest-php) < 3)
+# Ignore sebastian/comparator which will be loaded by phpunit autoloader
# remirepo:3
%else
Requires: php-hamcrest2
@@ -140,6 +142,10 @@ exit $ret
%changelog
+* Mon Nov 25 2019 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- use phpunit8
+
* Mon Sep 30 2019 Remi Collet <remi@remirepo.net> - 1.2.4-1
- update to 1.2.4
- drop patch merged upstream