summaryrefslogtreecommitdiffstats
path: root/php-mock-phpunit2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-mock-phpunit2.spec')
-rw-r--r--php-mock-phpunit2.spec51
1 files changed, 34 insertions, 17 deletions
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
index 4401195..771c77b 100644
--- a/php-mock-phpunit2.spec
+++ b/php-mock-phpunit2.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-mock-phpunit2
#
-# Copyright (c) 2016-2019 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 7df4bd123ce196bbba19f142c4906c20be8ec546
+%global gh_commit 2877a0e58f12e91b64bf36ccd080a209dcbf6c30
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock-phpunit
@@ -14,7 +14,7 @@
%global major 2
Name: php-mock-phpunit%{major}
-Version: 2.5.0
+Version: 2.6.0
Release: 1%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
@@ -27,41 +27,43 @@ BuildRequires: php(language) >= 7
%if %{with_tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(php-mock/php-mock-integration) >= 2 with php-composer(php-mock/php-mock-integration) < 3)
-BuildRequires: (php-composer(php-mock/php-mock) >= 2.1.1 with php-composer(php-mock/php-mock) < 3)
+BuildRequires: (php-composer(php-mock/php-mock-integration) >= 2.1 with php-composer(php-mock/php-mock-integration) < 3)
+BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
# remirepo:4
%else
-BuildRequires: php-mock-integration2
-BuildRequires: php-mock2 >= 2.1.1
+BuildRequires: php-mock-integration2 >= 2.1
+BuildRequires: php-mock2 >= 2.2
%endif
BuildRequires: phpunit6
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-BuildRequires: phpunit7
-%endif
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+BuildRequires: phpunit7
BuildRequires: phpunit8
%endif
+# remirepo:3
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
+BuildRequires: phpunit9
+%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# from composer.json, "require": {
# "php": ">=7",
-# "phpunit/phpunit": "^6 || ^7 || ^8",
-# "php-mock/php-mock-integration": "^2"
+# "phpunit/phpunit": "^6 || ^7 || ^8 || ^9",
+# "php-mock/php-mock-integration": "^2.1"
# "conflict": {
# "phpunit/phpunit-mock-objects": "3.2.0"
Requires: php(language) >= 7
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (phpunit6 or phpunit7 or phpunit8)
-Requires: (php-composer(php-mock/php-mock-integration) >= 2 with php-composer(php-mock/php-mock-integration) < 3)
-Requires: (php-composer(php-mock/php-mock) >= 2.1.1 with php-composer(php-mock/php-mock) < 3)
+Requires: (phpunit6 or phpunit7 or phpunit8 or phpunit9)
+Requires: (php-composer(php-mock/php-mock-integration) >= 2.1 with php-composer(php-mock/php-mock-integration) < 3)
+Requires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
# remirepo:5
%else
Requires: phpunit6
-Requires: php-mock-integration2
-Requires: php-mock2 >= 2.1.1
+Requires: php-mock-integration2 >= 2.1
+Requires: php-mock2 >= 2.2
%endif
# From phpcompatinfo report from version 2.1.0
# only Core
@@ -139,6 +141,15 @@ for cmd in php php72 php73 php74; do
fi
done
fi
+
+if [ -x %{_bindir}/phpunit9 ]; then
+: Run upstream test suite with phpunit9
+for cmd in php php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+done
+fi
exit $ret
%else
: bootstrap build with test suite disabled
@@ -155,6 +166,12 @@ exit $ret
%changelog
+* Mon Feb 10 2020 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on php-mock2 2.2
+- raise dependency on php-mock-integration2 2.1
+- allow phpunit9
+
* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 2.5.0-1
- update to 2.5.0