summaryrefslogtreecommitdiffstats
path: root/php-mock-phpunit2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-mock-phpunit2.spec')
-rw-r--r--php-mock-phpunit2.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
index 34a87db..4401195 100644
--- a/php-mock-phpunit2.spec
+++ b/php-mock-phpunit2.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 04f78fe83df4855654373188aca8cccf8bf472ce
+%global gh_commit 7df4bd123ce196bbba19f142c4906c20be8ec546
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock-phpunit
@@ -14,13 +14,13 @@
%global major 2
Name: php-mock-phpunit%{major}
-Version: 2.4.0
+Version: 2.5.0
Release: 1%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
License: WTFPL
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
BuildRequires: php(language) >= 7
@@ -124,7 +124,7 @@ done
if [ -x %{_bindir}/phpunit7 ]; then
: Run upstream test suite with phpunit7
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
@@ -133,7 +133,7 @@ fi
if [ -x %{_bindir}/phpunit8 ]; then
: Run upstream test suite with phpunit8
-for cmd in php php72 php73; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
@@ -146,6 +146,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -154,6 +155,9 @@ exit $ret
%changelog
+* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+
* Tue Jun 11 2019 Remi Collet <remi@remirepo.net> - 2.4.0-1
- update to 2.4.0