summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json30
-rw-r--r--php-mock-phpunit2.spec115
4 files changed, 157 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..9a1aa20
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,30 @@
+{
+ "name": "php-mock/php-mock-phpunit",
+ "type": "library",
+ "description": "Mock built-in PHP functions (e.g. time()) with PHPUnit. This package relies on PHP's namespace fallback policy. No further extension is needed.",
+ "keywords": ["phpunit", "mock", "stub", "test double", "function", "test", "TDD", "BDD"],
+ "homepage": "https://github.com/php-mock/php-mock-phpunit",
+ "license": "WTFPL",
+ "authors": [
+ {
+ "name": "Markus Malkusch",
+ "email": "markus@malkusch.de",
+ "homepage": "http://markus.malkusch.de",
+ "role": "Developer"
+ }
+ ],
+ "autoload": {
+ "psr-4": {"phpmock\\phpunit\\": "classes/"}
+ },
+ "require": {
+ "php": ">=5.5",
+ "phpunit/phpunit": "^4.0.0 || ^5.0.0",
+ "php-mock/php-mock-integration": "^1"
+ },
+ "archive": {
+ "exclude": ["/tests"]
+ },
+ "conflict": {
+ "phpunit/phpunit-mock-objects": "3.2.0"
+ }
+}
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
new file mode 100644
index 0000000..af998fc
--- /dev/null
+++ b/php-mock-phpunit2.spec
@@ -0,0 +1,115 @@
+# remirepo/fedora spec file for php-mock-phpunit
+#
+# Copyright (c) 2016-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 359e3038c016cee4c8f8db6387bcab3fcdebada0
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php-mock
+%global gh_project php-mock-phpunit
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-mock-phpunit
+Version: 1.1.2
+Release: 3%{?dist}
+Summary: Mock built-in PHP functions with PHPUnit.
+
+Group: Development/Libraries
+License: WTFPL
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 5.5
+%if %{with_tests}
+BuildRequires: php-composer(php-mock/php-mock-integration) < 2
+BuildRequires: php-composer(php-mock/php-mock-integration) >= 1
+BuildRequires: php-composer(phpunit/phpunit) > 4
+# For autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# from composer.json, "require": {
+# "php": ">=5.5",
+# "phpunit/phpunit": "^4.0.0 || ^5.0.0",
+# "php-mock/php-mock-integration": "^1"
+# "conflict": {
+# "phpunit/phpunit-mock-objects": "3.2.0"
+Requires: php(language) >= 5.5
+Requires: php-composer(phpunit/phpunit) >= 4
+Requires: php-composer(phpunit/phpunit) < 6
+Requires: php-composer(php-mock/php-mock-integration) >= 1
+Requires: php-composer(php-mock/php-mock-integration) < 2
+# From phpcompatinfo report from version 1.1.1
+# only Core
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Mock built-in PHP functions (e.g. time()) with PHPUnit.
+This package relies on PHP's namespace fallback policy.
+No further extension is needed.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+# Same namespace than php-mock, not specific autoloader needed
+
+
+%build
+# Nothing
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/
+mkdir -p %{buildroot}%{_datadir}/php/phpmock
+cp -pr classes %{buildroot}%{_datadir}/php/phpmock/phpunit
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+require_once '%{_datadir}/tests/phpmock/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('phpmock\\', '%{buildroot}%{_datadir}/php/phpmock');
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%{_datadir}/php/phpmock/phpunit
+
+
+%changelog
+* Thu May 11 2017 Remi Collet <remi@remirepo.net> - 1.1.2-3
+- switch to fedora/autoloader
+
+* Thu Jun 16 2016 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- update to 1.1.2 (no change)
+
+* Mon Feb 22 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-2
+- Fix: license is WTFPL
+
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- initial package