summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-mnapoli-phpunit-easymock-pr5.patch22
-rw-r--r--php-mnapoli-phpunit-easymock.spec11
2 files changed, 32 insertions, 1 deletions
diff --git a/php-mnapoli-phpunit-easymock-pr5.patch b/php-mnapoli-phpunit-easymock-pr5.patch
new file mode 100644
index 0000000..662f4f3
--- /dev/null
+++ b/php-mnapoli-phpunit-easymock-pr5.patch
@@ -0,0 +1,22 @@
+From 63a5d09b77a59b2c51b32eb3cead274efdccb6af Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Mon, 13 Jun 2016 16:56:47 +0200
+Subject: [PATCH] fix typo in test
+
+---
+ tests/EasyMockTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/EasyMockTest.php b/tests/EasyMockTest.php
+index cfddc9e..68f285a 100644
+--- a/tests/EasyMockTest.php
++++ b/tests/EasyMockTest.php
+@@ -138,7 +138,7 @@ public function should_allow_to_spy_method_calls()
+ $mock->__phpunit_verify();
+ $this->fail('Exception not thrown');
+ } catch (\PHPUnit_Framework_ExpectationFailedException $e) {
+- $this->assertContains('Expected invocation at least once but it never occured', $e->getMessage());
++ $this->assertContains('Expected invocation at least once but it never occur', $e->getMessage());
+ }
+
+ // Invoke the mock: the test should now pass
diff --git a/php-mnapoli-phpunit-easymock.spec b/php-mnapoli-phpunit-easymock.spec
index 8791187..0638681 100644
--- a/php-mnapoli-phpunit-easymock.spec
+++ b/php-mnapoli-phpunit-easymock.spec
@@ -31,7 +31,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 2%{?github_release}%{?dist}
Summary: Helpers to build PHPUnit mocks
Group: Development/Libraries
@@ -43,6 +43,9 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# https://github.com/mnapoli/phpunit-easymock/pull/5
+Patch0: %{name}-pr5.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
@@ -78,6 +81,8 @@ Autoloader: %{phpdir}/EasyMock/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1 -b .pr5
+
: Create autoloader
cat <<'AUTOLOAD' | tee src/autoload.php
<?php
@@ -154,6 +159,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Jun 13 2016 Remi Collet <remi@fedoraproject.org> - 0.2.2-2
+- add patch to fix test suite with latest PHPUnit
+ open https://github.com/mnapoli/phpunit-easymock/pull/5
+
* Sun Jun 05 2016 Shawn Iwinski <shawn@iwin.ski> - 0.2.2-1
- Updated to 0.2.2 (RHBZ #1342738)