summaryrefslogtreecommitdiffstats
path: root/php-marcusschwarz-lesserphp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-marcusschwarz-lesserphp.spec')
-rw-r--r--php-marcusschwarz-lesserphp.spec22
1 files changed, 19 insertions, 3 deletions
diff --git a/php-marcusschwarz-lesserphp.spec b/php-marcusschwarz-lesserphp.spec
index 1edeaae..1cefd29 100644
--- a/php-marcusschwarz-lesserphp.spec
+++ b/php-marcusschwarz-lesserphp.spec
@@ -1,3 +1,10 @@
+# remirepo spec file for php-marcusschwarz-lesserphp, from
+#
+# Fedora spec file for php-marcusschwarz-lesserphp
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
%global composer_vendor marcusschwarz
%global composer_project lesserphp
@@ -27,7 +34,7 @@ Patch0: lesserphp--pullrequest-18.patch
BuildArch: noarch
%if 0%{?with_tests}
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
+BuildRequires: phpunit7
%endif
BuildRequires: php-fedora-autoloader-devel
@@ -58,7 +65,8 @@ Autoloader: %{pkgdir}/autoload.php
%prep
-%autosetup -p1 -n %{repo_name}-%{version}
+%setup -n %{repo_name}-%{version}
+%patch0 -p1
# Lessify is broken upstream and we don't want to install it
rm lessify lessify.inc.php
@@ -91,11 +99,16 @@ install -m 0755 -p plessc %{buildroot}%{_bindir}/plessc
%check
%if 0%{?with_tests}
-phpunit --verbose --bootstrap %{buildroot}%{pkgdir}/autoload.php
+for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit7 --verbose --bootstrap %{buildroot}%{pkgdir}/autoload.php
+ fi
+done
%endif
%files
+%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -104,6 +117,9 @@ phpunit --verbose --bootstrap %{buildroot}%{pkgdir}/autoload.php
%changelog
+* Tue Mar 24 2020 Remi Collet <remi@remirepo.net> - 0.5.4-5
+- backport for remirepo
+
* Fri Mar 13 2020 Artur Iwicki <fedora@svgames.pl> - 0.5.4-5
- Fix FedoraAutoloader-related Requires/BuildRequires