summaryrefslogtreecommitdiffstats
path: root/php-league-mime-type-detection.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-league-mime-type-detection.spec')
-rw-r--r--php-league-mime-type-detection.spec17
1 files changed, 9 insertions, 8 deletions
diff --git a/php-league-mime-type-detection.spec b/php-league-mime-type-detection.spec
index 5473473..d514837 100644
--- a/php-league-mime-type-detection.spec
+++ b/php-league-mime-type-detection.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 3b9dff8aaf7323590c1d2e443db701eb1f9aa0d3
+%global gh_commit b38b25d7b372e9fddb00335400467b223349fd7e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project mime-type-detection
@@ -19,7 +19,7 @@
%global ns_project MimeTypeDetection
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.7.0
+Version: 1.8.0
Release: 1%{?dist}
Summary: Mime-type detection for Flysystem
@@ -38,13 +38,8 @@ BuildRequires: php-json
# "phpunit/phpunit": "^8.5.8 || ^9.3",
# "phpstan/phpstan": "^0.12.68",
# "friendsofphp/php-cs-fixer": "^2.18"
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
BuildRequires: phpunit9 >= 9.3
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8 >= 8.5.8
-%global phpunit %{_bindir}/phpunit8
-%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -95,10 +90,13 @@ cat << 'EOF' | tee vendor/autoload.php
require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
+# We don't want PHPStan
+sed -e 's/PHPStan\\Testing\\TestCase/PHPUnit\\Framework\\TestCase/' -i src/OverridingExtensionToMimeTypeMapTest.php
+
: Run upstream test suite
# the_generated_map_should_be_up_to_date is online
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -121,6 +119,9 @@ exit $ret
%changelog
+* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+
* Tue Jan 19 2021 Remi Collet <remi@remirepo.net> - 1.7.0-1
- update to 1.7.0