summaryrefslogtreecommitdiffstats
path: root/php-league-climate.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-league-climate.spec')
-rw-r--r--php-league-climate.spec26
1 files changed, 21 insertions, 5 deletions
diff --git a/php-league-climate.spec b/php-league-climate.spec
index cadec15..42e84cb 100644
--- a/php-league-climate.spec
+++ b/php-league-climate.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-league-climate
#
-# Copyright (c) 2016-2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner thephpleague
%global github_name climate
-%global github_version 3.2.1
-%global github_commit b103fc8faa3780c802cc507d5f0ff534ecc94fb5
+%global github_version 3.2.4
+%global github_commit ca70f67f7739cca823eba0ad98f8130bca226bf0
%global composer_vendor league
%global composer_project climate
@@ -39,7 +39,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Allows you to easily output colored text, special formats, and more
Group: Development/Libraries
@@ -56,13 +56,19 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(mikey179/vfsStream) >= %{vfsstream_min_ver} with php-composer(mikey179/vfsStream) < %{vfsstream_max_ver})
+BuildRequires: (php-composer(mockery/mockery) >= %{mockery_min_ver} with php-composer(mockery/mockery) < %{mockery_max_ver})
+BuildRequires: (php-composer(seld/cli-prompt) >= %{seld_cli_prompt_min_ver} with php-composer(seld/cli-prompt) < %{seld_cli_prompt_max_ver})
+%else
BuildRequires: php-composer(mikey179/vfsStream) < %{vfsstream_max_ver}
BuildRequires: php-composer(mikey179/vfsStream) >= %{vfsstream_min_ver}
BuildRequires: php-composer(mockery/mockery) < %{mockery_max_ver}
BuildRequires: php-composer(mockery/mockery) >= %{mockery_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(seld/cli-prompt) < %{seld_cli_prompt_max_ver}
BuildRequires: php-composer(seld/cli-prompt) >= %{seld_cli_prompt_min_ver}
+%endif
## phpcompatinfo (computed from version 3.2.1)
BuildRequires: php-json
BuildRequires: php-mbstring
@@ -76,8 +82,12 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(seld/cli-prompt) >= %{seld_cli_prompt_min_ver} with php-composer(seld/cli-prompt) < %{seld_cli_prompt_max_ver})
+%else
Requires: php-composer(seld/cli-prompt) >= %{seld_cli_prompt_min_ver}
Requires: php-composer(seld/cli-prompt) < %{seld_cli_prompt_max_ver}
+%endif
# phpcompatinfo (computed from version 3.2.1)
Requires: php-json
Requires: php-mbstring
@@ -172,6 +182,12 @@ exit $RETURN_CODE
%changelog
+* Mon Apr 23 2018 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.2.4-1
+- Update to 3.2.4 (RHBZ #1549561)
+- Update get source script to save source in same directory
+- Add range version dependencies for Fedora >= 27 || RHEL >= 8
+- Add composer.json to repo
+
* Mon May 15 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.2.1-3
- Switch autoloader to php-composer(fedora/autoloader)
- Add max versions to build dependencies