summaryrefslogtreecommitdiffstats
path: root/php-laminas-zendframework-bridge.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-zendframework-bridge.spec')
-rw-r--r--php-laminas-zendframework-bridge.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-laminas-zendframework-bridge.spec b/php-laminas-zendframework-bridge.spec
index 9c7059e..94b3359 100644
--- a/php-laminas-zendframework-bridge.spec
+++ b/php-laminas-zendframework-bridge.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4939c81f63a8a4968c108c440275c94955753b19
+%global gh_commit 6ede70583e101030bcace4dcddd648f760ddf642
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-zendframework-bridge
@@ -21,7 +21,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}
Summary: Alias legacy ZF class names to Laminas Project equivalents
@@ -41,8 +41,13 @@ BuildRequires: php-spl
# From composer, "require-dev": {
# "phpunit/phpunit": "^5.7 || ^6.5 || ^7.5 || ^8.1 || ^9.3",
# "squizlabs/php_codesniffer": "^3.5"
+%if 0%{?fedora} >= 32
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
+%else
%global phpunit %{_bindir}/phpunit8
BuildRequires: phpunit8 >= 8.1
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.1
%endif
@@ -159,10 +164,10 @@ php %{buildroot}%{php_home}/%{namespace}/autoload.php
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74 "php80 %{_bindir}/phpunit9"; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -185,6 +190,10 @@ exit $ret
%changelog
+* Tue Sep 15 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1 (no change)
+- switch to phpunit9
+
* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0 (no change)