summaryrefslogtreecommitdiffstats
path: root/php-laminas-xmlrpc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-xmlrpc.spec')
-rw-r--r--php-laminas-xmlrpc.spec13
1 files changed, 8 insertions, 5 deletions
diff --git a/php-laminas-xmlrpc.spec b/php-laminas-xmlrpc.spec
index b69a205..ab538b6 100644
--- a/php-laminas-xmlrpc.spec
+++ b/php-laminas-xmlrpc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9b5eba10ec4af8fa77193a0882ecf04cba2044ec
+%global gh_commit e94de8161821b6c82ba2892b398ad005f7be5ec3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xmlrpc
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.1
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -52,7 +52,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.3 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.2.1",
# "phpunit/phpunit": "^9.3"
# remirepo:8
%else
@@ -70,7 +70,7 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.4 || ~8.0.0",
# "laminas/laminas-http": "^2.5.4",
# "laminas/laminas-math": "^3.3.0",
# "laminas/laminas-server": "^2.9.1",
@@ -197,7 +197,7 @@ exit (class_exists("\\Zend\\%{library}\\Server") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -220,6 +220,9 @@ exit $ret
%changelog
+* Tue Oct 12 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+
* Tue Apr 20 2021 Remi Collet <remi@remirepo.net> - 2.10.1-1
- update to 2.10.1 (no change)
- raise dependency on laminas-xml 1.3