summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-22 09:55:28 +0200
committerRemi Collet <remi@php.net>2022-09-22 09:55:28 +0200
commitc69145a2f681beb125b8e1802ea1c3eea036095d (patch)
treee79e92ef7ce19c59226189ab29c97eac459311c6
parenteff0e4f2c8657147c1547cbcc2d491c157ffbeaa (diff)
update to 2.14.0HEADmaster
raise dependency on laminas-stdlib 3.10.1
-rw-r--r--composer.json15
-rw-r--r--php-laminas-xmlrpc.spec21
2 files changed, 23 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index bc3012d..99cb32c 100644
--- a/composer.json
+++ b/composer.json
@@ -17,6 +17,9 @@
},
"config": {
"sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
}
@@ -29,13 +32,14 @@
"laminas/laminas-http": "^2.15",
"laminas/laminas-math": "^3.4.0",
"laminas/laminas-server": "^2.11",
- "laminas/laminas-stdlib": "^3.6.1",
+ "laminas/laminas-stdlib": "^3.10.1",
"laminas/laminas-xml": "^1.4.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.2.1",
- "squizlabs/php_codesniffer": "^3.6.1",
- "phpunit/phpunit": "^9.5.8"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "^9.5.8",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24"
},
"suggest": {
"laminas/laminas-cache": "To support Laminas\\XmlRpc\\Server\\Cache usage"
@@ -61,7 +65,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"conflict": {
"zendframework/zend-xmlrpc": "*"
diff --git a/php-laminas-xmlrpc.spec b/php-laminas-xmlrpc.spec
index 13f0faa..d946f63 100644
--- a/php-laminas-xmlrpc.spec
+++ b/php-laminas-xmlrpc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f04ac9d5f33c2297b49b9fac78127a57fa90fa5f
+%global gh_commit 65674a9a39a7948c1555038c3808c9791a06823c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xmlrpc
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.13.1
+Version: 2.14.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -49,13 +49,14 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-code) >= 4.4
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11 with php-autoloader(%{gh_owner}/laminas-server) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.4 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.2.1",
-# "squizlabs/php_codesniffer": "^3.6.1",
-# "phpunit/phpunit": "^9.5.8"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.8",
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24"
# remirepo:9
%else
BuildRequires: php-laminas-code4
@@ -78,7 +79,7 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-http": "^2.15",
# "laminas/laminas-math": "^3.4.0",
# "laminas/laminas-server": "^2.11",
-# "laminas/laminas-stdlib": "^3.6.1",
+# "laminas/laminas-stdlib": "^3.10.1",
# "laminas/laminas-xml": "^1.4.0"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
@@ -88,7 +89,7 @@ Requires: (php-autoloader(%{gh_owner}/laminas-code) >= 4.4
Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11 with php-autoloader(%{gh_owner}/laminas-server) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.3 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.4 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
@@ -224,6 +225,10 @@ exit $ret
%changelog
+* Thu Sep 22 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0
+- raise dependency on laminas-stdlib 3.10.1
+
* Wed Sep 21 2022 Remi Collet <remi@remirepo.net> - 2.13.1-1
- update to 2.13.1