summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-08 15:31:50 +0100
committerRemi Collet <remi@remirepo.net>2020-01-08 15:31:50 +0100
commit7e8e1d761c885937006182db70767b8b644e08aa (patch)
tree921788e6a720e49702ce9b1dcf237280d2bec8cb
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json57
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-xml2json.spec167
5 files changed, 263 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..c416233
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,57 @@
+{
+ "name": "zendframework/zend-xml2json",
+ "description": "Provides functionality for converting XML to JSON, optionally including XML attributes",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf",
+ "zendframework",
+ "json",
+ "xml"
+ ],
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-xml2json/",
+ "issues": "https://github.com/zendframework/zend-xml2json/issues",
+ "source": "https://github.com/zendframework/zend-xml2json",
+ "rss": "https://github.com/zendframework/zend-xml2json/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-json": "^2.6.1 || ^3.0",
+ "zendframework/zendxml": "^1.0.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Xml2Json\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Xml2Json\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.1.x-dev",
+ "dev-develop": "3.2.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-xml2json.spec b/php-laminas-xml2json.spec
new file mode 100644
index 0000000..ca1c6f9
--- /dev/null
+++ b/php-laminas-xml2json.spec
@@ -0,0 +1,167 @@
+# remirepo/Fedora spec file for php-zendframework-zend-xml2json
+#
+# Copyright (c) 2016-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 43b08ce4b8350a9c0296d134a50f8e7c6e59b6cf
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-xml2json
+%global php_home %{_datadir}/php
+%global library Xml2Json
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 3.1.2
+Release: 1%{?dist}
+Summary: Provides functionality for converting XML to JSON
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:8
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
+BuildRequires: php-autoloader(%{gh_owner}/zendxml) < 2
+BuildRequires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-json": "^2.6.1 || ^3.0",
+# "zendframework/zendxml": "^1.0.2"
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
+# remirepo:6
+%else
+Requires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
+Requires: php-autoloader(%{gh_owner}/zend-json) < 4
+Requires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
+Requires: php-autoloader(%{gh_owner}/zendxml) < 2
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 3.0.0
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+zend-xml2json provides functionality for converting XML structures to JSON.
+
+* File issues at https://github.com/zendframework/zend-xml2json/issues
+* Documentation is at https://zendframework.github.io/zend-xml2json/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Json/autoload.php',
+ '%{php_home}/ZendXml/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Wed Oct 16 2019 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1
+- use range dependencies
+- switch to phpunit7
+
+* Wed Dec 6 2017 Remi Collet <remi@remirepo.net> - 3.1.0-2
+- switch from zend-loader to fedora/autoloader
+
+* Tue Oct 17 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- initial package
+