summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-07 08:43:17 +0100
committerRemi Collet <remi@remirepo.net>2021-01-07 08:43:17 +0100
commit4c58224111bd354ea7d223693fbc59d851d313c7 (patch)
tree9408c3ee395774d04891be489e48092818720d63
parent21d9b4ef0cf60a8141f43e23720195ef1737db16 (diff)
update to 2.12.0HEADmaster
raise dependency on PHP 7.3 raise dependency on laminas-stdlib 3.2.1 switch to phpunit9
-rw-r--r--composer.json17
-rw-r--r--php-laminas-view.spec50
2 files changed, 43 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 37d991e..4b96dca 100644
--- a/composer.json
+++ b/composer.json
@@ -18,14 +18,12 @@
"config": {
"sort-packages": true
},
- "extra": {
- },
"require": {
- "php": "^5.6 || ^7.0",
- "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+ "php": "^7.3 || ~8.0.0",
+ "laminas/laminas-eventmanager": "^3.0",
"laminas/laminas-json": "^2.6.1 || ^3.0",
"laminas/laminas-loader": "^2.5",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-stdlib": "^3.2.1",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
@@ -47,10 +45,15 @@
"laminas/laminas-permissions-acl": "^2.6",
"laminas/laminas-router": "^3.0.1",
"laminas/laminas-serializer": "^2.6.1",
- "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-servicemanager": "^3.3",
"laminas/laminas-session": "^2.8.1",
"laminas/laminas-uri": "^2.5",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.18"
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpspec/prophecy": "^1.12",
+ "phpunit/phpunit": "^9.3"
+ },
+ "conflict": {
+ "laminas/laminas-servicemanager": "<3.3"
},
"suggest": {
"laminas/laminas-authentication": "Laminas\\Authentication component",
diff --git a/php-laminas-view.spec b/php-laminas-view.spec
index 4bf7148..553ca0c 100644
--- a/php-laminas-view.spec
+++ b/php-laminas-view.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-view
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 1
-%global gh_commit 16611035d7b3a6ef2c636a9268c213146123b663
+%global gh_commit 3ef103da6887809f08ecf52f42c31a76c9bf08b1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-view
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.11.5
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -30,7 +30,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
BuildRequires: php-date
BuildRequires: php-dom
@@ -42,7 +42,7 @@ BuildRequires: php-spl
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 2.6.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-authentication": "^2.5",
@@ -63,10 +63,12 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-permissions-acl": "^2.6",
# "laminas/laminas-router": "^3.0.1",
# "laminas/laminas-serializer": "^2.6.1",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-servicemanager": "^3.3",
# "laminas/laminas-session": "^2.8.1",
# "laminas/laminas-uri": "^2.5",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.18"
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpspec/prophecy": "^1.12",
+# "phpunit/phpunit": "^9.3"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
@@ -86,10 +88,12 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-permissions-acl) >= 2.6
%endif
BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0.1 with php-autoloader(%{gh_owner}/laminas-router) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-serializer) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-serializer) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
-# remirepo:28
+BuildRequires: (php-composer(phpspec/prophecy) >= 1.12.0 with php-composer(phpspec/prophecy) < 2)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:30
%else
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-json
@@ -117,26 +121,28 @@ BuildRequires: php-laminas-serializer
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-session
BuildRequires: php-laminas-uri
+BuildRequires: php-phpspec-prophecy
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit7 >= 7.5.18
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-eventmanager": "^3.0",
# "laminas/laminas-json": "^2.6.1 || ^3.0",
# "laminas/laminas-loader": "^2.5",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-authentication": "Laminas\\Authentication component",
@@ -268,6 +274,10 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Prophecy/autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
+]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/%{namespace}/Cache/autoload.php',
'%{php_home}/%{namespace}/Config/autoload.php',
@@ -296,9 +306,9 @@ rm -r test/Helper*
: upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -319,6 +329,12 @@ exit $ret
%changelog
+* Thu Jan 7 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-stdlib 3.2.1
+- switch to phpunit9
+
* Wed Dec 16 2020 Remi Collet <remi@remirepo.net> - 2.11.5-1
- update to 2.11.5
- switch to phpunit7