summaryrefslogtreecommitdiffstats
path: root/php-laminas-validator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-validator.spec')
-rw-r--r--php-laminas-validator.spec59
1 files changed, 35 insertions, 24 deletions
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index 7f327a9..c73a01d 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -8,7 +8,7 @@
#
# When buid without config, db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit d334dddda43af263d6a7e5024fd2b013cb6981f7
+%global gh_commit 8da5e20ed7b2b8101c1de68ca8dc0180210ed23e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.13.5
+Version: 2.14.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -31,7 +31,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-fileinfo
@@ -42,7 +42,7 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-cache": "^2.6.1",
@@ -50,40 +50,41 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-config": "^2.6",
# "laminas/laminas-db": "^2.7",
# "laminas/laminas-filter": "^2.6",
-# "laminas/laminas-http": "^2.5.4",
+# "laminas/laminas-http": "^2.14.2",
# "laminas/laminas-i18n": "^2.6",
# "laminas/laminas-math": "^2.6",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-servicemanager": "^2.7.11 || ^3.0.3",
# "laminas/laminas-session": "^2.8",
-# "laminas/laminas-uri": "^2.5",
-# "phpunit/phpunit": "^7.5.20 || ^8.5.2",
+# "laminas/laminas-uri": "^2.7",
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.3",
+# "psalm/plugin-phpunit": "^0.15.0",
# "psr/http-client": "^1.0",
# "psr/http-factory": "^1.0",
-# "psr/http-message": "^1.0"
+# "psr/http-message": "^1.0",
+# "vimeo/psalm": "^4.3"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.6 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# ignore max version
BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.6 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.14.2 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8 with php-autoloader(%{gh_owner}/laminas-session) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.7 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
%endif
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
-# remirepo:20
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:21
%else
BuildRequires: php-container-interop
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-psr-http-message
-BuildRequires: php-psr-http-client
-BuildRequires: php-psr-http-factory
BuildRequires: php-laminas-cache
BuildRequires: php-laminas-i18n
BuildRequires: php-laminas-math
@@ -96,22 +97,26 @@ BuildRequires: php-laminas-http
BuildRequires: php-laminas-session
BuildRequires: php-laminas-uri
%endif
+BuildRequires: php-psr-http-message
+BuildRequires: php-psr-http-client
+BuildRequires: php-psr-http-factory
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit8 >= 8.5.2
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.1",
+# "php": "^7.3 || ~8.0.0",
# "container-interop/container-interop": "^1.1",
-# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-stdlib": "^3.3",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 7.1
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
@@ -227,6 +232,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Psr/Http/Client/autoload.php',
'%{php_home}/Psr/Http/Message/http-factory-autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -250,10 +256,9 @@ exit (class_exists("\\Zend\\%{library}\\Hex") ? 0 : 1);
: upstream test suite
ret=0
-# TODO PHP 8
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd -d memory_limit=1G %{_bindir}/phpunit8 --verbose || ret=1
+ $cmd -d memory_limit=1G %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -273,6 +278,12 @@ exit $ret
%changelog
+* Fri Jan 8 2021 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0
+- raise dependency on PHP 7.3
+- raise dependency on zend-stdlib 3.3
+- switch to phpunit9
+
* Thu Jan 7 2021 Remi Collet <remi@remirepo.net> - 2.13.5-1
- update to 2.13.5