summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-10 08:47:26 +0200
committerRemi Collet <remi@remirepo.net>2021-09-10 08:47:26 +0200
commit38b2d91e9dc4958e7b0edd40ec6331d204916054 (patch)
tree580c504dc04741caec6c2dba4e6b027e6371e8aa
parentdd4656e84954c20d0c918bf45fd78fd449c3e3d1 (diff)
update to 2.9.1HEADmaster
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader raise dependency on zend-escaper >= 2.9 raise dependency on zend-validator >= 2.15
-rw-r--r--composer.json15
-rw-r--r--php-laminas-uri.spec34
2 files changed, 27 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 2eb6043..34e1325 100644
--- a/composer.json
+++ b/composer.json
@@ -21,14 +21,13 @@
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-escaper": "^2.5",
- "laminas/laminas-validator": "^2.10",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "laminas/laminas-escaper": "^2.9",
+ "laminas/laminas-validator": "^2.15"
},
"require-dev": {
- "laminas/laminas-coding-standard": "^2.1",
- "phpunit/phpunit": "^9.3"
+ "laminas/laminas-coding-standard": "~2.2.1",
+ "phpunit/phpunit": "^9.5.5"
},
"autoload": {
"psr-4": {
@@ -50,7 +49,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-uri": "^2.7.1"
+ "conflict": {
+ "zendframework/zend-uri": "*"
}
}
diff --git a/php-laminas-uri.spec b/php-laminas-uri.spec
index 3ffb08c..418dee5 100644
--- a/php-laminas-uri.spec
+++ b/php-laminas-uri.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 79bd4c614c8cf9a6ba715a49fca8061e84933d87
+%global gh_commit 7e837dc15c8fd3949df7d1213246fd7c8640032b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-uri
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.1
+Version: 2.9.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -39,12 +39,12 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "^2.1",
-# "phpunit/phpunit": "^9.3"
+# "laminas/laminas-coding-standard": "^2.2.1",
+# "phpunit/phpunit": "^9.5.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.9 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:5
%else
@@ -53,21 +53,20 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-escaper": "^2.5",
-# "laminas/laminas-validator": "^2.10",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "laminas/laminas-escaper": "^2.9",
+# "laminas/laminas-validator": "^2.15"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.9 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:5
%else
@@ -154,7 +153,7 @@ exit (class_exists("\\Zend\\%{library}\\File") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -177,6 +176,13 @@ exit $ret
%changelog
+* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- update to 2.9.1
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on zend-escaper >= 2.9
+- raise dependency on zend-validator >= 2.15
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.1-1
- update to 2.8.1 (no change)