summaryrefslogtreecommitdiffstats
path: root/php-laminas-test.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-test.spec')
-rw-r--r--php-laminas-test.spec45
1 files changed, 27 insertions, 18 deletions
diff --git a/php-laminas-test.spec b/php-laminas-test.spec
index f862da2..b7e32f4 100644
--- a/php-laminas-test.spec
+++ b/php-laminas-test.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 42cdc13c2bf78199ed01f24f5cee735bcedaaad9
+%global gh_commit e2d0dec7872bbee214b9f2a9448e429d71b0e668
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-test
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 3.3.0
-Release: 2%{?dist}
+Version: 3.4.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -41,8 +41,9 @@ BuildRequires: phpunit6
BuildRequires: phpunit7
BuildRequires: phpunit8
# remirepo:1
+BuildRequires: phpunit9
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(sebastian/version) >= 1.0.4 with php-composer(sebastian/version) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-dom) >= 2.6 with php-autoloader(%{gh_owner}/laminas-dom) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
@@ -63,8 +64,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-serializer": "^2.6.1",
# "laminas/laminas-session": "^2.8.5",
# "laminas/laminas-validator": "^2.8",
-# "mikey179/vfsstream": "~1.2",
-# "symfony/finder": "^2.2"
+# "mikey179/vfsstream": "~1.2"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.6 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-log) >= 2.7.1 with php-autoloader(%{gh_owner}/laminas-log) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.7.1 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
@@ -74,9 +74,8 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-serializer) >= 2.6.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.8 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-composer(mikey179/vfsstream) >= 1.2 with php-composer(mikey179/vfsstream) < 2)
-# remirepo:11
+# remirepo:21
%else
-BuildRequires: php-phpunit-Version
BuildRequires: php-laminas-console
BuildRequires: php-laminas-dom
BuildRequires: php-laminas-eventmanager
@@ -97,7 +96,6 @@ BuildRequires: php-laminas-serializer
BuildRequires: php-laminas-session
BuildRequires: php-laminas-validator
%endif
-BuildRequires: php-symfony-finder
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -114,16 +112,17 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-uri": "^2.5",
# "laminas/laminas-view": "^2.6.3",
# "laminas/laminas-zendframework-bridge": "^1.0",
-# "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0 || ^7.0 || ^8.0",
-# "sebastian/version": "^1.0.4 || ^2.0"
+# "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0 || ^7.0 || ^8.0 || ^9.0",
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# Maintained versions
+Recommends: phpunit9
Recommends: phpunit8
-Recommends: phpunit7
-Recommends: phpunit6
-Recommends: phpunit
-Requires: (php-composer(sebastian/version) >= 1.0.4 with php-composer(sebastian/version) < 3)
+# EOL versions
+Suggests: phpunit7
+Suggests: phpunit6
+Suggests: phpunit
Requires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-dom) >= 2.6 with php-autoloader(%{gh_owner}/laminas-dom) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
@@ -137,9 +136,8 @@ Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer.json, "suggest": {
# "laminas/laminas-mvc-console": "^1.1.8, to test MVC <-> console integration"
Suggests: php-autoloader(%{gh_owner}/laminas-mvc-console)
-# remirepo:23
+# remirepo:12
%else
-Requires: php-phpunit-Version
Requires: php-laminas-console
Requires: php-laminas-dom
Requires: php-laminas-eventmanager
@@ -156,6 +154,7 @@ Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 3.3.0
Requires: php-pcre
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
@@ -236,7 +235,6 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/org/bovigo/vfs/autoload.php',
- '%{php_home}/Symfony/Component/Finder/autoload.php',
'%{php_home}/%{namespace}/I18n/autoload.php',
'%{php_home}/%{namespace}/Log/autoload.php',
'%{php_home}/%{namespace}/ModuleManager/autoload.php',
@@ -277,6 +275,13 @@ for cmd in php php72 php73 php74; do
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
done
+if [ -x %{_bindir}/phpunit9 ]; then
+ for cmd in php php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+ done
+fi
exit $ret
%else
: Test suite disabled
@@ -294,6 +299,10 @@ exit $ret
%changelog
+* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- allow phpunit9
+
* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 3.3.0-2
- only load phpunit-class-aliases if PHPUnit loaded