summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-laminas-test.spec50
2 files changed, 39 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index f08d48a..b5749fd 100644
--- a/composer.json
+++ b/composer.json
@@ -1,6 +1,6 @@
{
"name": "laminas/laminas-test",
- "description": "Tools to facilitate unit testing of laminas-mvc applications",
+ "description": "Tools to facilitate integration testing of laminas-mvc applications",
"license": "BSD-3-Clause",
"keywords": [
"laminas",
@@ -23,7 +23,6 @@
"require": {
"php": "^7.3 || ~8.0.0",
"laminas/laminas-console": "^2.6",
- "laminas/laminas-dom": "^2.8",
"laminas/laminas-eventmanager": "^3.0",
"laminas/laminas-http": "^2.13",
"laminas/laminas-mvc": "^3.0",
@@ -32,7 +31,9 @@
"laminas/laminas-uri": "^2.5",
"laminas/laminas-view": "^2.6.3",
"laminas/laminas-zendframework-bridge": "^1.1",
- "phpunit/phpunit": "^8.0 || ^9.0"
+ "phpunit/phpunit": "^8.4.3 || ^9.0",
+ "symfony/css-selector": "^5.4 || ^6.0",
+ "symfony/dom-crawler": "^5.4 || ^6.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.2.1",
diff --git a/php-laminas-test.spec b/php-laminas-test.spec
index 38ea2e8..4ba3ce8 100644
--- a/php-laminas-test.spec
+++ b/php-laminas-test.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 621eced0d747ead65c39ab0fc507f66e9bdca276
+%global gh_commit 72e879d2f9ef2fe3915eda9e329bf53b0b996b0c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-test
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.5.1
+Version: 3.6.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -41,7 +41,6 @@ BuildRequires: phpunit9
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-dom) >= 2.8 with php-autoloader(%{gh_owner}/laminas-dom) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.13 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
@@ -50,6 +49,8 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.6.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-composer(symfony/css-selector) >= 4 with php-composer(symfony/css-selector) < 7)
+BuildRequires: (php-composer(symfony/dom-crawler) >= 4 with php-composer(symfony/dom-crawler) < 7)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.2.1",
# "laminas/laminas-i18n": "^2.6",
@@ -72,10 +73,9 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-serializer) >= 2.6.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.8 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.8 with php-composer(mikey179/vfsstream) < 2)
-# remirepo:21
+# remirepo:22
%else
BuildRequires: php-laminas-console
-BuildRequires: php-laminas-dom
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-http
BuildRequires: php-laminas-mvc
@@ -93,6 +93,8 @@ BuildRequires: php-laminas-mvc-plugin-flashmessenger
BuildRequires: php-laminas-serializer
BuildRequires: php-laminas-session
BuildRequires: php-laminas-validator
+BuildRequires: php-symfony4-css-selector
+BuildRequires: php-symfony4-dom-crawler
%endif
%endif
# Autoloader
@@ -101,7 +103,6 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-console": "^2.6",
-# "laminas/laminas-dom": "^2.8",
# "laminas/laminas-eventmanager": "^3.0",
# "laminas/laminas-http": "^2.13",
# "laminas/laminas-mvc": "^3.0",
@@ -110,7 +111,9 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-uri": "^2.5",
# "laminas/laminas-view": "^2.6.3",
# "laminas/laminas-zendframework-bridge": "^1.1",
-# "phpunit/phpunit": "^8.0 || ^9.0"
+# "phpunit/phpunit": "^8.4.3 || ^9.0",
+# "symfony/css-selector": "^5.4 || ^6.0",
+# "symfony/dom-crawler": "^5.4 || ^6.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -118,7 +121,6 @@ Requires: php(language) >= 7.3
Recommends: phpunit9
Recommends: phpunit8
Requires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-dom) >= 2.8 with php-autoloader(%{gh_owner}/laminas-dom) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.13 with php-autoloader(%{gh_owner}/laminas-http) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
@@ -127,13 +129,15 @@ Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3
Requires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.6.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# ignore minimal version
+Requires: (php-composer(symfony/css-selector) >= 4 with php-composer(symfony/css-selector) < 7)
+Requires: (php-composer(symfony/dom-crawler) >= 4 with php-composer(symfony/dom-crawler) < 7)
# From composer.json, "suggest": {
# "laminas/laminas-mvc-console": "^1.1.8, to test MVC <-> console integration"
Suggests: php-autoloader(%{gh_owner}/laminas-mvc-console)
-# remirepo:12
+# remirepo:13
%else
Requires: php-laminas-console
-Requires: php-laminas-dom
Requires: php-laminas-eventmanager
Requires: php-laminas-http
Requires: php-laminas-mvc
@@ -142,6 +146,8 @@ Requires: php-laminas-stdlib
Requires: php-laminas-uri
Requires: php-laminas-view
Requires: php-laminas-zendframework-bridge
+Requires: php-symfony4-css-selector
+Requires: php-symfony4-dom-crawler
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -161,9 +167,9 @@ Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-The %{namespace}\Test component provides tools to facilitate unit testing of your
-%{namespace} Framework applications. At this time, we offer facilities to enable
-testing of your %{namespace} Framework MVC applications.
+The %{namespace}\Test component provides tools to facilitate integration
+testing of your %{namespace} Framework applications. At this time, we offer
+facilities to enable testing of your %{namespace} Framework MVC applications.
PHPUnit is the only library supported currently.
@@ -182,7 +188,6 @@ phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/Console/autoload.php',
- '%{php_home}/%{namespace}/Dom/autoload.php',
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Http/autoload.php',
'%{php_home}/%{namespace}/Mvc/autoload.php',
@@ -190,6 +195,15 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/%{namespace}/Stdlib/autoload.php',
'%{php_home}/%{namespace}/Uri/autoload.php',
'%{php_home}/%{namespace}/View/autoload.php',
+ [
+ '%{php_home}/Symfony6/Component/CssSelector/autoload.php',
+ '%{php_home}/Symfony5/Component/CssSelector/autoload.php',
+ '%{php_home}/Symfony4/Component/CssSelector/autoload.php',
+ ], [
+ '%{php_home}/Symfony6/Component/DomCrawler/autoload.php',
+ '%{php_home}/Symfony5/Component/DomCrawler/autoload.php',
+ '%{php_home}/Symfony4/Component/DomCrawler/autoload.php',
+ ],
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/%{namespace}/Mvc/Console/autoload.php',
@@ -253,7 +267,7 @@ if [ -x %{_bindir}/phpunit8 ]; then
fi
# TODO php81
if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php73 php74 php80; do
+ for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -276,6 +290,12 @@ exit $ret
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+- drop dependency on laminas-dom
+- add dependency on symfony/css-selector
+- add dependency on symfony/dom-crawler
+
* Mon Jun 14 2021 Remi Collet <remi@remirepo.net> - 3.5.1-1
- update to 3.5.1