summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-laminas-test.spec12
2 files changed, 8 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index f09c8fd..43a11ee 100644
--- a/composer.json
+++ b/composer.json
@@ -77,6 +77,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-test": "self.version"
+ "zendframework/zend-test": "^3.3.0"
}
}
diff --git a/php-laminas-test.spec b/php-laminas-test.spec
index b7e32f4..a407269 100644
--- a/php-laminas-test.spec
+++ b/php-laminas-test.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e2d0dec7872bbee214b9f2a9448e429d71b0e668
+%global gh_commit b540d62ca1d3efc0813cdb50bfaf8e4abcf88426
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-test
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.4.0
+Version: 3.4.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -40,7 +40,6 @@ BuildRequires: phpunit
BuildRequires: phpunit6
BuildRequires: phpunit7
BuildRequires: phpunit8
-# remirepo:1
BuildRequires: phpunit9
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -158,8 +157,8 @@ Requires: php-pcre
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.3.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 3.3.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -299,6 +298,9 @@ exit $ret
%changelog
+* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- update to 3.4.1
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0
- allow phpunit9