summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-20 13:25:35 +0200
committerRemi Collet <remi@php.net>2022-09-20 13:25:35 +0200
commit18fbb816cc588132c16f4ebd9e0ef98695923965 (patch)
tree9e6ee1ea6238f256f382aa2876c25bee93ba96ba
parent0cf348a0fda1a23b7aea0e26a481d2916c6bd904 (diff)
update to 3.13.0HEADmaster
raise dependency on PHP 7.4
-rw-r--r--composer.json11
-rw-r--r--php-laminas-stdlib.spec23
2 files changed, 20 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 05c5052..711b3fc 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.3.99"
+ "php": "7.4.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -27,14 +27,15 @@
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
+ "php": "^7.4 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.3.0",
- "phpbench/phpbench": "^1.0",
- "phpunit/phpunit": "^9.3.7",
+ "phpbench/phpbench": "^1.2.6",
+ "phpunit/phpunit": "^9.5.23",
"psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.7"
+ "vimeo/psalm": "^4.26",
+ "phpstan/phpdoc-parser": "^0.5.4"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-stdlib.spec b/php-laminas-stdlib.spec
index 8a7caa5..7a61841 100644
--- a/php-laminas-stdlib.spec
+++ b/php-laminas-stdlib.spec
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit aad7d2b11ba0069ba0d9b40f6dde3c2fa664b57f
+%global gh_commit 66a6d03c381f6c9f1dd988bf8244f9afb9380d76
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-stdlib
@@ -23,7 +23,7 @@
%global library Stdlib
Name: php-%{gh_project}
-Version: 3.11.0
+Version: 3.13.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -51,19 +51,20 @@ BuildRequires: php-posix
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpbench/phpbench": "^1.0",
-# "phpunit/phpunit": "^9.3.7",
+# "phpbench/phpbench": "^1.2.6",
+# "phpunit/phpunit": "^9.5.23",
# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.7"
+# "vimeo/psalm": "^4.26",
+# "phpstan/phpdoc-parser": "^0.5.4"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3.7
+BuildRequires: phpunit9 >= 9.5.23
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0"
-Requires: php(language) >= 7.3
+# "php": "^7.4 || ~8.0.0 || ~8.1.0"
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# only require for compatibility layer
@@ -175,6 +176,10 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 3.13.0-1
+- update to 3.13.0
+- raise dependency on PHP 7.4
+
* Thu Jul 28 2022 Remi Collet <remi@remirepo.net> - 3.11.0-1
- update to 3.11.0