summaryrefslogtreecommitdiffstats
path: root/php-laminas-servicemanager.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-servicemanager.spec')
-rw-r--r--php-laminas-servicemanager.spec48
1 files changed, 32 insertions, 16 deletions
diff --git a/php-laminas-servicemanager.spec b/php-laminas-servicemanager.spec
index fb344bd..4ad45b9 100644
--- a/php-laminas-servicemanager.spec
+++ b/php-laminas-servicemanager.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-servicemanager
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0d4c8628a71fae9f7bd0b1b74b76382e5e9a04b1
+%global gh_commit d55e4e78fc7c9bbef1e9e098dada979eeef04439
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-servicemanager
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.4.1
+Version: 3.6.1
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -55,34 +55,40 @@ BuildRequires: php-date
BuildRequires: php-json
BuildRequires: php-spl
# From composer, "require-dev": {
+# "composer/package-versions-deprecated": "^1.0",
# "laminas/laminas-coding-standard": "~1.0.0",
-# "mikey179/vfsstream": "^1.6.5",
-# "ocramius/proxy-manager": "^1.0 || ^2.0",
-# "phpbench/phpbench": "^0.13.0",
-# "phpunit/phpunit": "^5.7.25 || ^6.4.4"
+# "laminas/laminas-container-config-test": "^0.3",
+# "laminas/laminas-dependency-plugin": "^2.1",
+# "mikey179/vfsstream": "^1.6.8",
+# "ocramius/proxy-manager": "^2.2.3",
+# "phpbench/phpbench": "^1.0.0-alpha3",
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.5 with php-composer(mikey179/vfsstream) < 2)
-BuildRequires: (php-composer(ocramius/proxy-manager) >= 1.0 with php-composer(ocramius/proxy-manager) < 3)
-# remirepo:6
+BuildRequires: (php-composer(ocramius/proxy-manager) >= 2.2 with php-composer(ocramius/proxy-manager) < 3)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:7
%else
BuildRequires: php-composer(mikey179/vfsStream) < 2
BuildRequires: php-composer(mikey179/vfsStream) >= 1.6.5
BuildRequires: php-composer(ocramius/proxy-manager) < 4
BuildRequires: php-composer(ocramius/proxy-manager) >= 1.0
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit6 >= 6.4.4
+BuildRequires: phpunit9 >= 9.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ^8.0.0",
# "container-interop/container-interop": "^1.2",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/container": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
@@ -106,7 +112,7 @@ Requires: php-spl
%if ! %{bootstrap}
# From composer, "suggest": {
# "laminas/laminas-stdlib": "laminas-stdlib ^2.5 if you wish to use the MergeReplaceKey or MergeRemoveKey features in Config instances",
-# "ocramius/proxy-manager": "ProxyManager 1.* to handle lazy initialization of services"
+# "ocramius/proxy-manager": "ProxyManager ^2.1.1 to handle lazy initialization of services"
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-composer(ocramius/proxy-manager)
%endif
@@ -183,15 +189,20 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Bench\\%{library}\\', dirname(__DIR__) . '/benchmarks');
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/org/bovigo/vfs/autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
EOF
+# test using laminas/laminas-container-config-test
+rm test/ContainerTest.php
+
ret=0
-for cmd in php php72 php73 php74 php80; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
done
@@ -218,6 +229,11 @@ exit $ret
%changelog
+* Mon Jan 11 2021 Remi Collet <remi@remirepo.net> - 3.6.1-1
+- update to 3.6.1
+- raise dependency on PHP 7.3
+- switch to phpunit 9
+
* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 3.4.1-1
- update to 3.4.1