summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-11 11:03:11 +0200
committerRemi Collet <remi@php.net>2021-10-11 11:03:11 +0200
commitfc3d23f9392f5acd27b708b307d47b1fe9a7d472 (patch)
tree611ee4e1b9f6e10d182fd2996489b6999562085e
parent3a7613a397cd739e70fcf4b6858a7816da8d5ea3 (diff)
update to 2.11.0HEADmaster
-rw-r--r--composer.json4
-rw-r--r--php-laminas-server.spec15
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 6618daa..5e0bc3b 100644
--- a/composer.json
+++ b/composer.json
@@ -21,14 +21,14 @@
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-code": "^3.5.1 || ^4.0.0",
"laminas/laminas-stdlib": "^3.3.1",
"laminas/laminas-zendframework-bridge": "^1.2.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.5.4",
+ "phpunit/phpunit": "^9.5.5",
"psalm/plugin-phpunit": "^0.15.1",
"vimeo/psalm": "^4.6.4"
},
diff --git a/php-laminas-server.spec b/php-laminas-server.spec
index a9933a1..cd8b880 100644
--- a/php-laminas-server.spec
+++ b/php-laminas-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e1fd6853223feed7a00555144d661e0a914124cd
+%global gh_commit 7582832d56c5488dee4d4753bf3bf2d5f3dc5906
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-server
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.0
+Version: 2.11.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -40,7 +40,7 @@ BuildRequires: php-spl
BuildRequires: php-reflection
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.5.4",
+# "phpunit/phpunit": "^9.5.5",
# "psalm/plugin-phpunit": "^0.15.1",
#+ "vimeo/psalm": "^4.6.4"
# remirepo:1
@@ -55,13 +55,13 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.4
+BuildRequires: phpunit9 >= 9.5.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-code": "^3.5.1 || ^4.0.0",
# "laminas/laminas-stdlib": "^3.3.1",
# "laminas/laminas-zendframework-bridge": "^1.2.0"
@@ -159,7 +159,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -189,6 +189,9 @@ exit $ret
%changelog
+* Mon Oct 11 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+
* Fri Apr 16 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0
- raise dependency on laminas-code 3.5.1 and allow v4