summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-16 10:36:54 +0100
committerRemi Collet <remi@php.net>2022-11-16 10:36:54 +0100
commitd127c80a4be8323a94b2e02bd0454ad5533f6527 (patch)
tree5f52162888422b28122a7995fec4bd0fae18751d
parent3e57cad16cc5f71b6bd1d750af8390bfdc7d0672 (diff)
update to 2.12.0 (no change)
raise dependency on PHP 8.0
-rw-r--r--composer.json7
-rw-r--r--php-laminas-server.spec16
2 files changed, 14 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 000d1ac..83f07d9 100644
--- a/composer.json
+++ b/composer.json
@@ -18,16 +18,17 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.3.99"
+ "php": "8.0.99"
},
"allow-plugins": {
- "composer/package-versions-deprecated": true
+ "composer/package-versions-deprecated": true,
+ "dealerdirect/phpcodesniffer-composer-installer": true
}
},
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-code": "^3.5.1 || ^4.0.0",
"laminas/laminas-stdlib": "^3.3.1",
"laminas/laminas-zendframework-bridge": "^1.2.0"
diff --git a/php-laminas-server.spec b/php-laminas-server.spec
index 5d36148..15a464f 100644
--- a/php-laminas-server.spec
+++ b/php-laminas-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f45e1a6f614a11af8eff5d2d409f12229101cfc1
+%global gh_commit c249f0638c8bdd67305509b7173bd535c21d109d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-server
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.11.1
+Version: 2.12.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-reflection
@@ -61,11 +61,11 @@ BuildRequires: phpunit9 >= 9.5.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-code": "^3.5.1 || ^4.0.0",
# "laminas/laminas-stdlib": "^3.3.1",
# "laminas/laminas-zendframework-bridge": "^1.2.0"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -160,7 +160,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -190,6 +190,10 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0 (no change)
+- raise dependency on PHP 8.0
+
* Mon Feb 28 2022 Remi Collet <remi@remirepo.net> - 2.11.1-1
- update to 2.11.1