summaryrefslogtreecommitdiffstats
path: root/php-laminas-router.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-router.spec')
-rw-r--r--php-laminas-router.spec32
1 files changed, 19 insertions, 13 deletions
diff --git a/php-laminas-router.spec b/php-laminas-router.spec
index 694697f..eef3412 100644
--- a/php-laminas-router.spec
+++ b/php-laminas-router.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 01a6905202ad41a42ba63d60260eba32b89e18c7
+%global gh_commit 163fc498e9e4ac3253cd8254ef738fa9fd141f61
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-router
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.3.2
+Version: 3.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
@@ -42,12 +42,12 @@ BuildRequires: php-spl
BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-i18n": "^2.7.4",
-# "phpunit/phpunit": "^5.7.22 || ^6.4.1 || ^7.5.18"
+# "phpunit/phpunit": "^9.4"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.6 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# remirepo:8
%else
@@ -58,27 +58,27 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-i18n
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.18
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "container-interop/container-interop": "^1.2",
# "laminas/laminas-http": "^2.8.1",
# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
-# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-stdlib": "^3.3",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-http) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "zendframework/zend-i18n": "^2.6, if defining translatable HTTP path segments"
@@ -188,10 +188,10 @@ exit (class_exists("\\Zend\\%{library}\\RouterFactory") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -211,6 +211,12 @@ exit $ret
%changelog
+* Wed Nov 18 2020 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- raise dependency on PHP 7.3
+- raise dependency on zendframework/zend-stdlib 3.3
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 3.3.2-1
- update to 3.3.2 (no change)