summaryrefslogtreecommitdiffstats
path: root/php-laminas-recaptcha.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-recaptcha.spec')
-rw-r--r--php-laminas-recaptcha.spec164
1 files changed, 91 insertions, 73 deletions
diff --git a/php-laminas-recaptcha.spec b/php-laminas-recaptcha.spec
index 862d40d..708ddb5 100644
--- a/php-laminas-recaptcha.spec
+++ b/php-laminas-recaptcha.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zendservice-recaptcha
+# remirepo/Fedora spec file for php-laminas-recaptcha
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -6,23 +6,23 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit b21625c54f19ba5be5c90ab9fa167ca075cd1594
+%global gh_commit f84222c958c9784db8bcc5b37a8021e5ffcb9557
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project ZendService_ReCaptcha
-%global pk_project zendservice-recaptcha
+%global gh_owner laminas
+%global gh_project laminas-recaptcha
+%global zf_name zendservice-recaptcha
%global php_home %{_datadir}/php
-%global namespace ZendService
+%global namespace Laminas
%global library ReCaptcha
%global with_tests 0%{!?_without_tests:1}
-Name: php-%{gh_owner}-%{pk_project}
+Name: php-%{gh_project}
Version: 3.2.0
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://framework.zend.com/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -33,72 +33,76 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.5.4 with php-autoloader(%{gh_owner}/zend-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^2.0",
-# "zendframework/zend-validator": "^2.8.2"
-BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.0 with php-autoloader(%{gh_owner}/zend-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.8.2 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.5
-# remirepo:14
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-config": "^2.0",
+# "laminas/laminas-validator": "^2.8.2",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.0 with php-autoloader(%{gh_owner}/laminas-config) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.8.2 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+# remirepo:8
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.8.2
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-http
+BuildRequires: php-laminas-json
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-config
+BuildRequires: php-laminas-validator
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-http": "^2.5.4",
-# "zendframework/zend-json": "^2.6.1 || ^3.0",
-# "zendframework/zend-stdlib": "^3.2.1"
+# "laminas/laminas-http": "^2.5.4",
+# "laminas/laminas-json": "^2.6.1 || ^3.0",
+# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-http) >= 2.5.4 with php-autoloader(%{gh_owner}/zend-http) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:8
+Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "laminas/laminas-validator": "~2.0, if using ReCaptcha's Mailhide API"
+Suggests: php-autoloader(%{gh_owner}/laminas-validator)
+# remirepo:6
%else
-Requires: php-autoloader(%{gh_owner}/zend-http) < 3
-Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
-Requires: php-autoloader(%{gh_owner}/zend-json) < 4
-Requires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+Requires: php-laminas-http
+Requires: php-laminas-json
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
-# From compsoer, "suggest": {
-# "zendframework/zend-validator": "~2.0, if using ReCaptcha's Mailhide API"
-Suggests: php-autoloader(%{gh_owner}/zend-validator)
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 3.0.0 (mcrypt is optional)
+# From phpcompatinfo report for version 3.2.0 (mcrypt is optional)
Requires: php-json
-Provides: php-composer(%{gh_owner}/%{pk_project}) = %{version}
-Provides: php-autoloader(%{gh_owner}/%{pk_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 3.2.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
%{summary}.
+OOP wrapper for the ReCaptcha web service.
+
+Documentation: https://docs.laminas.dev/%{gh_project}/
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -107,34 +111,37 @@ mv LICENSE.md LICENSE
%build
-: Generate autoloader for this framework extension - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-Zend\Loader\AutoloaderFactory::factory(array(
- 'Zend\Loader\StandardAutoloader' => array(
- 'namespaces' => array(
- '%{namespace}\\%{library}' => dirname(__DIR__) . '/%{namespace}/%{library}',
-))));
-EOF
-
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Http/autoload.php',
- '%{php_home}/Zend/Json/autoload.php',
+ '%{php_home}/%{namespace}/Http/autoload.php',
+ '%{php_home}/%{namespace}/Json/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/%{namespace}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
-install -Dpm 644 autoload.php %{buildroot}%{php_home}/Zend/%{namespace}-%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/ZendService/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/ZendService/%{library}/autoload.php
%check
@@ -144,14 +151,21 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Config/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendServiceTest\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/ZendService/%{library}/autoload.php";
+exit (class_exists("\\ZendService\\%{library}\\ReCaptcha") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --exclude online --verbose || ret=1
@@ -164,16 +178,20 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
-%dir %{php_home}/%{namespace}
+%dir %{php_home}/ZendService
+ %{php_home}/ZendService/%{library}
%{php_home}/%{namespace}/%{library}
- %{php_home}/Zend/%{namespace}-%{library}-autoload.php
%changelog
+* Mon Jan 13 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- switch to Laminas
+
* Fri Feb 8 2019 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0
- add dependency on zend-stdlib 3.2.1