summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-laminas-math.spec15
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 1677bc4..9b7c5a5 100644
--- a/composer.json
+++ b/composer.json
@@ -25,13 +25,13 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"ext-mbstring": "*",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^9.5.5"
},
"suggest": {
"ext-bcmath": "If using the bcmath functionality",
diff --git a/php-laminas-math.spec b/php-laminas-math.spec
index fb066b3..208d3cd 100644
--- a/php-laminas-math.spec
+++ b/php-laminas-math.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 188456530923a449470963837c25560f1fdd8a60
+%global gh_commit 79f6453a47a5774cf3736c5c66cb4818486681da
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-math
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.3.2
+Version: 3.4.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -51,15 +51,15 @@ BuildRequires: php-spl
BuildRequires: php-mcrypt
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.3"
+# "phpunit/phpunit": "^9.5.5"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.5
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "ext-mbstring": "*",
# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 7.3
@@ -154,7 +154,7 @@ if [ "$(id -un)" != "remi" ]; then
filter="--filter '^((?!(testRandFloat)).)*$'"
fi
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -186,6 +186,9 @@ exit $ret
%changelog
+* Mon Oct 11 2021 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 3.3.2-1
- update to 3.3.2