summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--134.patch51
-rw-r--r--composer.json1
-rw-r--r--php-laminas-mail.spec15
3 files changed, 11 insertions, 56 deletions
diff --git a/134.patch b/134.patch
deleted file mode 100644
index db8475d..0000000
--- a/134.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From b5e38613811824a6d1b3d1993f37de422087ac6f Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 26 Jan 2021 17:42:09 +0100
-Subject: [PATCH 1/2] fix TypeError: fclose(): supplied resource is not a valid
- stream resource
-
----
- src/Storage/Mbox.php | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/Storage/Mbox.php b/src/Storage/Mbox.php
-index 3e48a6c6..52f6bcfe 100644
---- a/src/Storage/Mbox.php
-+++ b/src/Storage/Mbox.php
-@@ -308,7 +308,9 @@ protected function openMboxFile($filename)
- public function close()
- {
- ErrorHandler::start(E_WARNING);
-- fclose($this->fh);
-+ if (is_resource($this->fh)) {
-+ fclose($this->fh);
-+ }
- ErrorHandler::stop();
- $this->positions = [];
- }
-
-From fd62569b1065b85eadad627e0556376e1696da97 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 26 Jan 2021 17:54:35 +0100
-Subject: [PATCH 2/2] clean uneeded stuff
-
----
- src/Storage/Mbox.php | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/src/Storage/Mbox.php b/src/Storage/Mbox.php
-index 52f6bcfe..c8f16d6e 100644
---- a/src/Storage/Mbox.php
-+++ b/src/Storage/Mbox.php
-@@ -307,11 +307,9 @@ protected function openMboxFile($filename)
- */
- public function close()
- {
-- ErrorHandler::start(E_WARNING);
- if (is_resource($this->fh)) {
- fclose($this->fh);
- }
-- ErrorHandler::stop();
- $this->positions = [];
- }
-
diff --git a/composer.json b/composer.json
index aa5ded6..f5ee58c 100644
--- a/composer.json
+++ b/composer.json
@@ -32,6 +32,7 @@
"laminas/laminas-stdlib": "^2.7 || ^3.0",
"laminas/laminas-validator": "^2.10.2",
"laminas/laminas-zendframework-bridge": "^1.0",
+ "symfony/polyfill-mbstring": "^1.12.0",
"true/punycode": "^2.1"
},
"require-dev": {
diff --git a/php-laminas-mail.spec b/php-laminas-mail.spec
index e25228a..09bb0a7 100644
--- a/php-laminas-mail.spec
+++ b/php-laminas-mail.spec
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit a259ddb091618bdcbfb1540e0fe4671a823c342b
+%global gh_commit 6f6fb7c6f332abea25461eefb3da15e104edfd56
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mail
@@ -18,7 +18,7 @@
%global library Mail
Name: php-%{gh_project}
-Version: 2.13.0
+Version: 2.13.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -27,8 +27,6 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-mail/pull/134.patch
-
BuildArch: noarch
# Tests
%if %{with tests}
@@ -36,6 +34,7 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-iconv
+BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
@@ -81,9 +80,11 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-stdlib": "^2.7 || ^3.0",
# "laminas/laminas-validator": "^2.10.2",
# "laminas/laminas-zendframework-bridge": "^1.0",
+# "symfony/polyfill-mbstring": "^1.12.0",
# "true/punycode": "^2.1"
Requires: php(language) >= 7.3
Requires: php-iconv
+Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
@@ -140,7 +141,6 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -225,6 +225,11 @@ exit $ret
%changelog
+* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 2.13.1-1
+- update to 2.13.1
+- drop patch merged upstream
+- add dependency on mbstring extension
+
* Tue Jan 26 2021 Remi Collet <remi@remirepo.net> - 2.13.0-1
- update to 2.13.0
- raise dependency on PHP 7.3