summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-20 17:15:45 +0200
committerRemi Collet <remi@php.net>2022-09-20 17:15:45 +0200
commit5c066884ffaa21d21c9c7552897a8ab81dc55d17 (patch)
treec21bd4064ed2eaa85181f27b4ba6b772c6f36e8d
parentfcc32d6050faa79484a2cb09dbbcd8f73e8e2fc5 (diff)
update to 2.18.0HEADmaster
raise dependency on laminas-mime 2.10
-rw-r--r--composer.json4
-rw-r--r--php-laminas-mail.spec16
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 2bf66e0..3207f5a 100644
--- a/composer.json
+++ b/composer.json
@@ -11,7 +11,7 @@
"php": "~8.0.0 || ~8.1.0",
"ext-iconv": "*",
"laminas/laminas-loader": "^2.8.0",
- "laminas/laminas-mime": "^2.9.1",
+ "laminas/laminas-mime": "^2.10.0",
"laminas/laminas-stdlib": "^3.11.0",
"laminas/laminas-validator": "^2.23.0",
"symfony/polyfill-mbstring": "^1.16.0",
@@ -19,7 +19,7 @@
"symfony/polyfill-intl-idn": "^1.26.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
+ "laminas/laminas-coding-standard": "~2.4.0",
"laminas/laminas-crypt": "^3.8.0",
"laminas/laminas-db": "^2.15.0",
"laminas/laminas-servicemanager": "^3.16.0",
diff --git a/php-laminas-mail.spec b/php-laminas-mail.spec
index 05c08b1..b73f76c 100644
--- a/php-laminas-mail.spec
+++ b/php-laminas-mail.spec
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit bf7504247d5a110d941efa8eb4815f5292a8dc56
+%global gh_commit 0976a33ca997c803379f9a4641d4942dfb79b2cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mail
@@ -18,7 +18,7 @@
%global library Mail
Name: php-%{gh_project}
-Version: 2.17.0
+Version: 2.18.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -41,13 +41,13 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.8.0 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-mime) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.10 with php-autoloader(%{gh_owner}/laminas-mime) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.11.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.23.0 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-composer(webmozart/assert) >= 1.11.0 with php-composer(webmozart/assert) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
# "laminas/laminas-crypt": "^3.8.0",
# "laminas/laminas-db": "^2.15.0",
# "laminas/laminas-servicemanager": "^3.16.0",
@@ -83,7 +83,7 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "~8.0.0 || ~8.1.0",
# "ext-iconv": "*",
# "laminas/laminas-loader": "^2.8.0",
-# "laminas/laminas-mime": "^2.9.1",
+# "laminas/laminas-mime": "^2.10.0",
# "laminas/laminas-stdlib": "^3.11.0",
# "laminas/laminas-validator": "^2.23.0",
# "symfony/polyfill-mbstring": "^1.162.0",
@@ -95,7 +95,7 @@ Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.8.0 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-mime) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.10 with php-autoloader(%{gh_owner}/laminas-mime) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.11.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.23.0 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -241,6 +241,10 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.18.0-1
+- update to 2.18.0
+- raise dependency on laminas-mime 2.10
+
* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
- update to 2.17.0
- raise dependency on laminas-stdlib 3.11.0