summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-16 09:44:57 +0100
committerRemi Collet <remi@php.net>2022-11-16 09:44:57 +0100
commit6de9c483f421088bbe319344557895e6e0c1b2a6 (patch)
treebc3f3fde3ca71deaebbaeba32c99bc3c358538ea
parent1ded16c4f832ace6209d1267b6bb25b640e1419d (diff)
update to 2.16.0 (no change)HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json7
-rw-r--r--php-laminas-log.spec14
2 files changed, 14 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 458ec4c..62538d2 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,10 @@
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
},
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "8.0.99"
+ }
},
"extra": {
"laminas": {
@@ -29,7 +32,7 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-servicemanager": "^3.3.0",
"laminas/laminas-stdlib": "^3.0",
"psr/log": "^1.1.2"
diff --git a/php-laminas-log.spec b/php-laminas-log.spec
index 20d011e..72eba98 100644
--- a/php-laminas-log.spec
+++ b/php-laminas-log.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1deab9c4bc484bbe21be5f0119a90e91d0da548c
+%global gh_commit 932a4b95b4cbb64dc69fb56ad3cd5032d5995104
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-log
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.15.3
+Version: 2.16.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -92,11 +92,11 @@ BuildRequires: php-autoloader(%{gh_owner}/laminas-mime) >= 2.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-servicemanager": "^3.3.0",
# "laminas/laminas-stdlib": "^3.0",
# "psr/log": "^1.1.2"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -249,6 +249,10 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0 (no change)
+- raise dependency on PHP 8.0
+
* Thu Oct 27 2022 Remi Collet <remi@remirepo.net> - 2.15.3-1
- update to 2.15.3