summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json34
-rw-r--r--php-laminas-ldap.spec93
2 files changed, 83 insertions, 44 deletions
diff --git a/composer.json b/composer.json
index 7362e5f..fbbf681 100644
--- a/composer.json
+++ b/composer.json
@@ -16,26 +16,29 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "platform": {
+ "php": "8.0.99"
+ },
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.10.x-dev",
- "dev-develop": "2.11.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
- "ext-ldap": "*",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+ "ext-ldap": "*"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-config": "^2.5",
- "laminas/laminas-eventmanager": "^2.6.3 || ^3.0.1",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
- "php-mock/php-mock-phpunit": "^1.1.2 || ^2.1.1",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "laminas/laminas-config": "^3.8.0",
+ "laminas/laminas-eventmanager": "^3.6.0",
+ "laminas/laminas-stdlib": "^3.15.0",
+ "php-mock/php-mock-phpunit": "^2.6.1",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^5.0.0"
},
"suggest": {
"laminas/laminas-eventmanager": "Laminas\\EventManager component"
@@ -57,10 +60,11 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-ldap": "self.version"
+ "conflict": {
+ "zendframework/zend-ldap": "*"
}
}
diff --git a/php-laminas-ldap.spec b/php-laminas-ldap.spec
index 95400cc..05dc545 100644
--- a/php-laminas-ldap.spec
+++ b/php-laminas-ldap.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-ldap
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7410927ff02ddc8e5d0e1c0e93079599d7788d8d
+%global gh_commit cb66c477ec2fd2a7f38527c59d0635a9166b6597
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-ldap
@@ -22,11 +22,11 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.2
+Version: 2.17.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -34,32 +34,34 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ldap
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^2.5",
-# "laminas/laminas-eventmanager": "^2.6.3 || ^3.0.1",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
-# "php-mock/php-mock-phpunit": "^1.1.2 || ^2.1.1",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.5 with php-autoloader(%{gh_owner}/laminas-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0.1 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.1.1 with php-composer(php-mock/php-mock-phpunit) < 3)
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "laminas/laminas-config": "^3.8.0",
+# "laminas/laminas-eventmanager": "^3.6.0",
+# "laminas/laminas-stdlib": "^3.15.0",
+# "php-mock/php-mock-phpunit": "^2.6.1",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^5.0.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.8 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.15 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.6.1 with php-composer(php-mock/php-mock-phpunit) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-config
+BuildRequires: php-laminas-config3
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-mock-phpunit2
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.20
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.25
BuildRequires: php-date
BuildRequires: php-iconv
BuildRequires: php-json
@@ -71,14 +73,13 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "ext-ldap": "*",
-# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+# "ext-ldap": "*"
+Requires: php(language) >= 8.0
Requires: php-ldap
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-eventmanager": "Laminas\\EventManager component"
Suggests: php-autoloader(%{gh_owner}/laminas-eventmanager)
@@ -100,8 +101,8 @@ Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.10.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.10.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -126,7 +127,7 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config3/autoload.php',
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
@@ -174,10 +175,10 @@ exit (class_exists("\\Zend\\%{library}\\Ldap") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} || ret=1
fi
done
exit $ret
@@ -197,6 +198,40 @@ exit $ret
%changelog
+* Wed Dec 21 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0
+- raise dependency on PHP 8.0
+
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+
+* Thu Aug 4 2022 Remi Collet <remi@remirepo.net> - 2.14.1-1
+- update to 2.14.1
+
+* Mon Aug 1 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0
+- raise dependency on PHP 7.4
+
+* Mon Mar 21 2022 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
+* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-zendframework-bridge 1.1
+- switch to phpunit9
+
+* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.10.3-1
+- update to 2.10.3 (no change)
+
* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 2.10.2-1
- update to 2.10.2