summaryrefslogtreecommitdiffstats
path: root/php-laminas-ldap.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-10 11:38:08 +0100
committerRemi Collet <remi@remirepo.net>2020-01-10 11:38:08 +0100
commite79929b8e199096e271761f1547719b61d67437b (patch)
tree24dc6877252a7b85ae13035730124fb0dfe4e35d /php-laminas-ldap.spec
duplicate ZF
Diffstat (limited to 'php-laminas-ldap.spec')
-rw-r--r--php-laminas-ldap.spec201
1 files changed, 201 insertions, 0 deletions
diff --git a/php-laminas-ldap.spec b/php-laminas-ldap.spec
new file mode 100644
index 0000000..2319f51
--- /dev/null
+++ b/php-laminas-ldap.spec
@@ -0,0 +1,201 @@
+# remirepo/Fedora spec file for php-zendframework-zend-ldap
+#
+# Copyright (c) 2015-2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 525ec97cd18a42a953c6a78c1019f967d2539b88
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-ldap
+%global php_home %{_datadir}/php
+%global library Ldap
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.10.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-ldap
+BuildRequires: php-date
+BuildRequires: php-iconv
+BuildRequires: php-json
+BuildRequires: php-mbstring
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "php-mock/php-mock-phpunit": "^1.1.2 || ^2.1.1",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^2.5",
+# "zendframework/zend-eventmanager": "^2.6.3 || ^3.0.1",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.3
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel8}
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+BuildRequires: (php-mock-phpunit2 >= 2.1.1 with php-mock-phpunit2 < 3)
+# remirepo:5
+%else
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-mock-phpunit2 >= 2.1.1
+%endif
+BuildRequires: php-composer(phpunit/phpunit) >= 4.6
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "ext-ldap": "*"
+Requires: php(language) >= 5.6
+Requires: php-ldap
+%if ! %{bootstrap}
+# From composer, "suggest": {
+# "zendframework/zend-eventmanager": "Zend\\EventManager component"
+# remirepo:1
+%if 0%{?fedora} >= 21 || 0%{?rhel8}
+Suggests: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.3
+# remirepo:1
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.10.0
+Requires: php-date
+Requires: php-iconv
+Requires: php-json
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Ldap\Ldap is a class for performing LDAP operations including but
+not limited to binding, searching and modifying entries in an LDAP directory.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/Config/autoload.php',
+ '%{php_home}/Zend/EventManager/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/phpmock2/phpunit/autoload.php',
+]);
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+# Need investigation
+sed -e 's/PHPUnit_Util_ErrorHandler/IGNORE_PHPUnit_Util_ErrorHandler/' -i test/ErrorHandlerTest.php
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/Zend
+ %{php_home}/Zend/%{library}
+
+
+%changelog
+* Fri Oct 18 2019 Remi Collet <remi@remirepo.net> - 2.10.1-1
+- update to 2.10.1 (no change)
+
+* Thu Jul 5 2018 Remi Collet <remi@remirepo.net> - 2.10.0-2
+- update to 2.10.0
+
+* Wed Apr 25 2018 Remi Collet <remi@remirepo.net> - 2.9.0-2
+- update to 2.9.0
+- raise dependency on PHP 5.6
+- switch to phpunit6 or phpunit7
+
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.8.0-3
+- switch from zend-loader to fedora/autoloader
+
+* Tue Mar 7 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- Update to 2.8.0
+
+* Wed May 25 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
+- update to 2.7.1
+
+* Fri Apr 22 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+- dependency on zend-stdlib is now optional
+
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
+- update to 2.6.1
+
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-2
+- add build dependency on php-mock-phpunit
+
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package