summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-13 06:52:16 +0100
committerRemi Collet <remi@remirepo.net>2021-01-13 06:52:16 +0100
commit5f560d0819fd0db51dd037be69c2d8b0efe62e63 (patch)
tree06ba5ba6983ed9a839a13ad353ec6aefd947f177
parent125214c6b10a0f21af18324a24b0e1e46026f99f (diff)
update to 2.11.0HEADmaster
raise dependency on PHP 7.3 raise dependency on laminas-zendframework-bridge 1.1 switch to phpunit9
-rw-r--r--composer.json18
-rw-r--r--php-laminas-ldap.spec54
2 files changed, 37 insertions, 35 deletions
diff --git a/composer.json b/composer.json
index b926070..d0434be 100644
--- a/composer.json
+++ b/composer.json
@@ -19,23 +19,19 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.10.x-dev",
- "dev-develop": "2.11.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"ext-ldap": "*",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-zendframework-bridge": "^1.1"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-config": "^2.5",
- "laminas/laminas-eventmanager": "^2.6.3 || ^3.0.1",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
- "php-mock/php-mock-phpunit": "^1.1.2 || ^2.1.1",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
+ "laminas/laminas-config": "^3.4",
+ "laminas/laminas-eventmanager": "^3.3",
+ "laminas/laminas-stdlib": "^3.3",
+ "php-mock/php-mock-phpunit": "^2.6",
+ "phpunit/phpunit": "^9.5.0"
},
"suggest": {
"laminas/laminas-eventmanager": "Laminas\\EventManager component"
diff --git a/php-laminas-ldap.spec b/php-laminas-ldap.spec
index 30ee317..7af3633 100644
--- a/php-laminas-ldap.spec
+++ b/php-laminas-ldap.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-ldap
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 649fae8982149b93071c4a7d56f2c4efeed51aa8
+%global gh_commit c1370452cd6548e103fb181d8e6e1fca9954dba4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-ldap
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.3
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,22 +34,22 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ldap
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^2.5",
-# "laminas/laminas-eventmanager": "^2.6.3 || ^3.0.1",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
-# "php-mock/php-mock-phpunit": "^1.1.2 || ^2.1.1",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.5 with php-autoloader(%{gh_owner}/laminas-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0.1 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.1.1 with php-composer(php-mock/php-mock-phpunit) < 3)
+# "laminas/laminas-config": "^3.4",
+# "laminas/laminas-eventmanager": "^3.3",
+# "laminas/laminas-stdlib": "^3.3",
+# "php-mock/php-mock-phpunit": "^2.6",
+# "phpunit/phpunit": "^9.5.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.6 with php-composer(php-mock/php-mock-phpunit) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-zendframework-bridge
@@ -58,8 +58,8 @@ BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-mock-phpunit2
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.20
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.0
BuildRequires: php-date
BuildRequires: php-iconv
BuildRequires: php-json
@@ -71,14 +71,14 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "ext-ldap": "*",
-# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+# "laminas/laminas-zendframework-bridge": "^1.1"
+Requires: php(language) >= 7.3
Requires: php-ldap
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-eventmanager": "Laminas\\EventManager component"
Suggests: php-autoloader(%{gh_owner}/laminas-eventmanager)
@@ -101,7 +101,7 @@ Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
Obsoletes: php-zendframework-%{zf_name} < 2.10.2
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -126,7 +126,7 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config3/autoload.php',
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
@@ -174,10 +174,10 @@ exit (class_exists("\\Zend\\%{library}\\Ldap") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} || ret=1
fi
done
exit $ret
@@ -197,6 +197,12 @@ exit $ret
%changelog
+* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-zendframework-bridge 1.1
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.10.3-1
- update to 2.10.3 (no change)