summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json9
-rw-r--r--php-laminas-json-server.spec29
2 files changed, 21 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index bb618f9..ed683ca 100644
--- a/composer.json
+++ b/composer.json
@@ -21,21 +21,18 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "3.2.x-dev",
- "dev-develop": "3.3.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-http": "^2.7",
"laminas/laminas-json": "^2.6.1 || ^3.0",
"laminas/laminas-server": "^2.7",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
+ "ext-json": "*",
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpunit/phpunit": "^9.3.0"
},
"conflict": {
"laminas/laminas-stdlib": "<3.2.1"
diff --git a/php-laminas-json-server.spec b/php-laminas-json-server.spec
index 0b77a5a..dfb4386 100644
--- a/php-laminas-json-server.spec
+++ b/php-laminas-json-server.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-json-server
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5580959966a99bc110066566ca8965773ef49c13
+%global gh_commit 45a55cbdcec6806c6f8cc81e40df5c9738269a0f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json-server
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.2
+Version: 3.3.0
Release: 1%{?dist}
Summary: %{namespace} Json-Server is a JSON-RPC server implementation
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -46,8 +46,9 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0
BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
+# "ext-json": "*",
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+# "phpunit/phpunit": "^9.3.0"
# remirepo:6
%else
BuildRequires: php-laminas-http
@@ -55,19 +56,20 @@ BuildRequires: php-laminas-json
BuildRequires: php-laminas-server
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+BuildRequires: php-json
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3.0
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-http": "^2.7",
# "laminas/laminas-json": "^2.6.1 || ^3.0",
# "laminas/laminas-server": "^2.7",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
@@ -158,10 +160,10 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Response") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -181,6 +183,11 @@ exit $ret
%changelog
+* Thu Apr 8 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 3.2.2-1
- update to 3.2.2