summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json31
-rw-r--r--php-laminas-json-server.spec86
2 files changed, 77 insertions, 40 deletions
diff --git a/composer.json b/composer.json
index a569100..b03083c 100644
--- a/composer.json
+++ b/composer.json
@@ -18,24 +18,26 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "3.2.x-dev",
- "dev-develop": "3.3.x-dev"
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
}
},
"require": {
- "php": "^5.6 || ^7.0",
- "laminas/laminas-http": "^2.7",
- "laminas/laminas-json": "^2.6.1 || ^3.0",
- "laminas/laminas-server": "^2.7",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.4 || ~8.0.0 || ~8.1.0 || ~8.2.0",
+ "laminas/laminas-http": "^2.15.1",
+ "laminas/laminas-json": "^3.3.0",
+ "laminas/laminas-server": "^2.11.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "ext-json": "*",
+ "laminas/laminas-coding-standard": "^2.4.0",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^5.0.0"
},
"conflict": {
"laminas/laminas-stdlib": "<3.2.1"
@@ -60,10 +62,11 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-json-server": "self.version"
+ "zendframework/zend-json-server": "^3.2.0"
}
}
diff --git a/php-laminas-json-server.spec b/php-laminas-json-server.spec
index c89f1e3..84479d4 100644
--- a/php-laminas-json-server.spec
+++ b/php-laminas-json-server.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-json-server
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2023 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f3e9c1488dd7588d3fe808be5cf53999166fb29d
+%global gh_commit c997f45abdec80fbb5c666588b9c3e529560242b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json-server
@@ -23,11 +23,11 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.0
+Version: 3.8.0
Release: 1%{?dist}
Summary: %{namespace} Json-Server is a JSON-RPC server implementation
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,44 +35,47 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.4
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15.1 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.3 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11 with php-autoloader(%{gh_owner}/laminas-server) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
-# remirepo:10
+# "ext-json": "*",
+# "laminas/laminas-coding-standard": "^2.4.0",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^5.0.0"
+# remirepo:6
%else
BuildRequires: php-laminas-http
BuildRequires: php-laminas-json
BuildRequires: php-laminas-server
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+BuildRequires: php-json
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-http": "^2.7",
-# "laminas/laminas-json": "^2.6.1 || ^3.0",
-# "laminas/laminas-server": "^2.7",
-# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+# "php": "^7.4 || ~8.0.0 || ~8.1.0 || ~8.2.0",
+# "laminas/laminas-http": "^2.15.1",
+# "laminas/laminas-json": "^3.3.0",
+# "laminas/laminas-server": "^2.11.0",
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15.1 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.3 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11 with php-autoloader(%{gh_owner}/laminas-server) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:6
%else
@@ -89,8 +92,8 @@ Requires: php-reflection
Requires: php-spl
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.2.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 3.2.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -158,10 +161,10 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Response") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -181,6 +184,37 @@ exit $ret
%changelog
+* Tue Mar 28 2023 Remi Collet <remi@remirepo.net> - 3.8.0-1
+- update to 3.8.0
+
+* Tue Dec 13 2022 Remi Collet <remi@remirepo.net> - 3.7.0-1
+- update to 3.7.0
+
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+
+* Fri Feb 4 2022 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0
+
+* Mon Jan 10 2022 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- raise dependency on laminas-http 2.15.1
+- raise dependency on laminas-json 3.3.0
+- raise dependency on laminas-server 2.11.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
+* Thu Apr 8 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
+* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 3.2.2-1
+- update to 3.2.2
+
+* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1
+
* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
- switch to Laminas