summaryrefslogtreecommitdiffstats
path: root/php-laminas-feed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-feed.spec')
-rw-r--r--php-laminas-feed.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/php-laminas-feed.spec b/php-laminas-feed.spec
index 63005e3..6e4de9b 100644
--- a/php-laminas-feed.spec
+++ b/php-laminas-feed.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 64d25e18a6ea3db90c27fe2d6b95630daa1bf602
+%global gh_commit c9356994eb80d0f6b46d7e12ba048d450bf0cd72
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-feed
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.0
+Version: 2.12.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -50,10 +50,10 @@ BuildRequires: php-tidy
# "laminas/laminas-http": "^2.7",
# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
# "laminas/laminas-validator": "^2.10.1",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20",
# "psr/http-message": "^1.0.1"
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.4.3
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.5.20
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
@@ -128,6 +128,7 @@ Requires: php-pcre
Requires: php-spl
Requires: php-tidy
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
@@ -213,7 +214,7 @@ ret=0
for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
- $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -233,6 +234,10 @@ exit $ret
%changelog
+* Mon Mar 23 2020 Remi Collet <remi@remirepo.net> - 2.12.1-1
+- update to 2.12.1
+- switch to phpunit7
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.12.0-1
- switch to Laminas