summaryrefslogtreecommitdiffstats
path: root/php-laminas-feed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-feed.spec')
-rw-r--r--php-laminas-feed.spec202
1 files changed, 110 insertions, 92 deletions
diff --git a/php-laminas-feed.spec b/php-laminas-feed.spec
index 4096f85..63005e3 100644
--- a/php-laminas-feed.spec
+++ b/php-laminas-feed.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-feed
+# remirepo/Fedora spec file for php-laminas-feed
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d926c5af34b93a0121d5e2641af34ddb1533d733
+%global gh_commit 64d25e18a6ea3db90c27fe2d6b95630daa1bf602
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-feed
+%global gh_owner laminas
+%global gh_project laminas-feed
+%global zf_name zend-feed
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Feed
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.12.0
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -42,44 +44,38 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tidy
# From composer, "require-dev": {
+# "laminas/laminas-cache": "^2.7.2",
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-db": "^2.8.2",
+# "laminas/laminas-http": "^2.7",
+# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
+# "laminas/laminas-validator": "^2.10.1",
# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
-# "psr/http-message": "^1.0.1",
-# "zendframework/zend-cache": "^2.7.2",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-db": "^2.8.2",
-# "zendframework/zend-http": "^2.7",
-# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
-# "zendframework/zend-validator": "^2.10.1"
+# "psr/http-message": "^1.0.1"
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6 >= 6.4.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.7.2 with php-autoloader(%{gh_owner}/zend-cache) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-db) >= 2.8.2 with php-autoloader(%{gh_owner}/zend-db) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.8 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-# remirepo:18
+BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.8.2 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+# remirepo:11
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-BuildRequires: php-composer(psr/http-message) < 2
-BuildRequires: php-composer(psr/http-message) >= 1.0.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.7.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-db) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.8.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.8
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+BuildRequires: php-psr-http-message
+BuildRequires: php-laminas-escaper
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-cache
+BuildRequires: php-laminas-db
+BuildRequires: php-laminas-http
+BuildRequires: php-laminas-servicemanager
+BuildRequires: php-laminas-validator
%endif
%endif
# Autoloader
@@ -89,42 +85,42 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^5.6 || ^7.0",
# "ext-dom": "*",
# "ext-libxml": "*",
-# "zendframework/zend-escaper": "^2.5.2",
-# "zendframework/zend-stdlib": "^3.2.1"
+# "laminas/laminas-escaper": "^2.5.2",
+# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
Requires: php-dom
Requires: php-libxml
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
-# remirepo:8
+Requires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "laminas/laminas-cache": "Laminas\\Cache component, for optionally caching feeds between requests",
+# "laminas/laminas-db": "Laminas\\Db component, for use with PubSubHubbub",
+# "laminas/laminas-http": "Laminas\\Http for PubSubHubbub, and optionally for use with Laminas\\Feed\\Reader",
+# "laminas/laminas-servicemanager": "Laminas\\ServiceManager component, for easily extending ExtensionManager implementations",
+# "laminas/laminas-validator": "Laminas\\Validator component, for validating email addresses used in Atom feeds and entries when using the Writer subcomponent",
+# "psr/http-message": "PSR-7 ^1.0.1, if you wish to use Laminas\\Feed\\Reader\\Http\\Psr7ResponseDecorator"
+Suggests: php-autoloader(%{gh_owner}/laminas-cache)
+Suggests: php-autoloader(%{gh_owner}/laminas-db)
+Suggests: php-autoloader(%{gh_owner}/laminas-http)
+Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
+Suggests: php-autoloader(%{gh_owner}/laminas-validator)
+# remirepo:6
%else
-Requires: php-autoloader(%{gh_owner}/zend-escaper) < 3
-Requires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-Requires: php-composer(psr/http-message) < 2
-Requires: php-composer(psr/http-message) >= 1.0.1
+Requires: php-psr-http-message
+Requires: php-laminas-escaper
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
-# From composer, "suggest": {
-# "psr/http-message": "PSR-7 ^1.0.1, if you wish to use Zend\\Feed\\Reader\\Http\\Psr7ResponseDecorator",
-# "zendframework/zend-cache": "Zend\\Cache component, for optionally caching feeds between requests",
-# "zendframework/zend-db": "Zend\\Db component, for use with PubSubHubbub",
-# "zendframework/zend-http": "Zend\\Http for PubSubHubbub, and optionally for use with Zend\\Feed\\Reader",
-# "zendframework/zend-servicemanager": "Zend\\ServiceManager component, for easily extending ExtensionManager implementations",
-# "zendframework/zend-validator": "Zend\\Validator component, for validating feeds and Atom entries in the Writer subcomponent"
-Suggests: php-autoloader(%{gh_owner}/zend-cache)
-Suggests: php-autoloader(%{gh_owner}/zend-db)
-Suggests: php-autoloader(%{gh_owner}/zend-http)
-Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
-Suggests: php-autoloader(%{gh_owner}/zend-validator)
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.6.0
+# From phpcompatinfo report for version 2.12.0
Requires: php-ctype
Requires: php-date
Requires: php-hash
@@ -132,20 +128,25 @@ Requires: php-pcre
Requires: php-spl
Requires: php-tidy
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.12.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Feed provides functionality for consuming RSS and Atom feeds.
+%{namespace}\Feed provides functionality for consuming RSS and Atom feeds.
It provides a natural syntax for accessing elements of feeds, feed attributes,
-and entry attributes. Zend\Feed also has extensive support for modifying feed
-and entry structure with the same natural syntax, and turning the result back
-into XML.
+and entry attributes. %{namespace}\Feed also has extensive support for modifying
+feed and entry structure with the same natural syntax, and turning the result
+back into XML.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -155,35 +156,41 @@ mv LICENSE.md LICENSE
%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/Psr/Http/Message/autoload.php';
-EOF
-
: Generate autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Escaper/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Escaper/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
'%{php_home}/Psr/Http/Message/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Cache/autoload.php',
- '%{php_home}/Zend/Db/autoload.php',
- '%{php_home}/Zend/Http/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Cache/autoload.php',
+ '%{php_home}/%{namespace}/Db/autoload.php',
+ '%{php_home}/%{namespace}/Http/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -191,12 +198,19 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\Uri") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -209,15 +223,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
-%{php_home}/Zend/%{library}-autoload.php
+%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- switch to Laminas
+
* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0