summaryrefslogtreecommitdiffstats
path: root/php-laminas-diactoros2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-diactoros2.spec')
-rw-r--r--php-laminas-diactoros2.spec47
1 files changed, 29 insertions, 18 deletions
diff --git a/php-laminas-diactoros2.spec b/php-laminas-diactoros2.spec
index 9981a51..feaa896 100644
--- a/php-laminas-diactoros2.spec
+++ b/php-laminas-diactoros2.spec
@@ -11,7 +11,7 @@
%global gh_owner laminas
%global gh_project laminas-diactoros
%global zf_name zend-diactoros
-%global gh_commit 36ef09b73e884135d2059cc498c938e90821bb57
+%global gh_commit 4ff7400c1c12e404144992ef43c8b733fd9ad516
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global php_home %{_datadir}/php
%global namespace Laminas
@@ -21,14 +21,14 @@
%global gh_psr7_owner php-http
%global gh_psr7_name psr7-integration-tests
-%global gh_psr7_version 1.0.0
-%global gh_psr7_commit c3bb79ca4a276df57364ff45bf2f619f769ded4a
+%global gh_psr7_version 1.1.0
+%global gh_psr7_commit b63c2f50c114a474086c6801aea58c0aa96f9b27
%global gh_psr7_short %(c=%{gh_psr7_commit}; echo ${c:0:7})
%global gh_factory_owner http-interop
%global gh_factory_name http-factory-tests
-%global gh_factory_version 0.6.0
-%global gh_factory_commit 92d8b91e7236957d7512ef93e8a237d241671ce7
+%global gh_factory_version 0.8.0
+%global gh_factory_commit 7384d93cd4841647b16b3c9bfd56c0367a40fce1
%global gh_factory_short %(c=%{gh_factory_commit}; echo ${c:0:7})
# Build using "--without tests" to disable tests
@@ -37,7 +37,7 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{gh_project}%{major}
-Version: 2.4.1
+Version: 2.5.0
Release: 1%{?gh_release}%{?dist}
Summary: PSR HTTP Message implementations v%{major}
@@ -59,30 +59,33 @@ BuildArch: noarch
# Tests
%if %{with tests}
## composer.json
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
-# remirepo:4
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:6
%else
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-psr-http-message
BuildRequires: php-psr-http-factory
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
# "require-dev": {
# "ext-curl": "*",
# "ext-dom": "*",
# "ext-gd": "*",
# "ext-libxml": "*",
-# "http-interop/http-factory-tests": "^0.5.0",
+# "http-interop/http-factory-tests": "^0.8.0",
# "laminas/laminas-coding-standard": "~1.0.0",
-# "php-http/psr7-integration-tests": "dev-master",
-# "phpunit/phpunit": "^7.5.18"
+# "php-http/psr7-integration-tests": "^1.1",
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.1"
# },
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.18
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
BuildRequires: php-curl
BuildRequires: php-dom
BuildRequires: php-gd
@@ -101,17 +104,17 @@ BuildRequires: php-fedora-autoloader-devel
# composer.json
# "require": {
-# "php": "^7.1",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/http-factory": "^1.0",
# "psr/http-message": "^1.0"
-Requires: php(language) >= 7.1
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
Requires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
-# remirepo:4
+# remirepo:5
%else
Requires: php-laminas-zendframework-bridge
Requires: php-psr-http-message
@@ -213,6 +216,9 @@ cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
require_once '%{buildroot}%{phpdir}/%{namespace}/%{library}%{major}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Prophecy/PhpUnit/autoload.php',
+]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', __DIR__.'/test');
\Fedora\Autoloader\Autoload::addPsr4('Http\\Psr7Test\\', __DIR__.'/psr7/src');
\Fedora\Autoloader\Autoload::addPsr4('Interop\\Http\\Factory\\', __DIR__.'/factory/test');
@@ -221,10 +227,10 @@ BOOTSTRAP
: Upstream tests
# Skip tests requiring network access
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php72 php73 php74; do
+for CMDARG in "php %{phpunit}" php73 php74 php80; do
if which $CMDARG; then
set $CMDARG
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--bootstrap bootstrap.php \
--filter '^((?!(testReasonPhraseDefaultsAgainstIana|testIsNotSeekable|testIsNotWritable|testIsNotReadable|testRewindNotSeekable)).)*$' \
--verbose || RETURN_CODE=1
@@ -254,6 +260,11 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 19 2020 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Sep 4 2020 Remi Collet <remi@remirepo.net> - 2.4.1-1
- update to 2.4.1 (no change)