summaryrefslogtreecommitdiffstats
path: root/php-laminas-di.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-di.spec')
-rw-r--r--php-laminas-di.spec26
1 files changed, 14 insertions, 12 deletions
diff --git a/php-laminas-di.spec b/php-laminas-di.spec
index ad82879..c45f713 100644
--- a/php-laminas-di.spec
+++ b/php-laminas-di.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-di
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,7 +22,7 @@
Name: php-%{gh_project}
Version: 2.6.1
-Release: 5%{?dist}
+Release: 8%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -39,14 +39,13 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-code) >= 3.0 with php-autoloader(%{gh_owner}/laminas-code) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
-# remirepo:7
+# remirepo:6
%else
-BuildRequires: php-composer(container-interop/container-interop) < 2
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-laminas-servicemanager >= 3.12
BuildRequires: php-laminas-code
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
@@ -69,14 +68,13 @@ Requires: php(language) >= 5.7
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-code) >= 3.0 with php-autoloader(%{gh_owner}/laminas-code) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
-# remirepo:7
+# remirepo:6
%else
-Requires: php-composer(container-interop/container-interop) >= 1.1
-Requires: php-composer(container-interop/container-interop) < 2
+Requires: php-laminas-servicemanager >= 3.12
Requires: php-laminas-code
Requires: php-laminas-stdlib
Requires: php-laminas-zendframework-bridge
@@ -121,7 +119,7 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
'%{php_home}/%{namespace}/Code/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
@@ -157,7 +155,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--verbose || ret=1
@@ -187,6 +185,10 @@ exit $ret
%changelog
+* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 3.7.0-2
+- drop dependency on container-interop/container-interop
+ replaced by servicemanager >= 3.12
+
* Thu Feb 4 2021 Remi Collet <remi@remirepo.net> - 2.6.1-5
- disable test suite, fix FTBFS #1923569